Nautilus is very slow to start, help?

Hey all,

For some reason, Nautilus is very slow to start. I got to a slow count of 15 from when I hit enter in the terminal, to when Nautilus finally showed up. And I seen it slower. It also seems to make file open/save dialogs in other apps slow. Like when saving a pdf via Firefox.

The terminal I launched Nautilus from shows no error messages.

Nothing useful shows up in system logs either. journalctl -a --followJust:

Sep 09 20:28:16 mysystem gnome-shell[6176]: Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x7000007

While researching this issue, I found a lot of posts about Tracker and NFS slowing things down. But when I disable Tracker via Settings -> Search -> Toggle in top right, it doesn’t make any difference. That is the right way to turn Tracker off, right?

Then I found some mention of having NFS mount in the root of my home directory causing issues. So I moved all my NFS mounts into a sub directory. It didn’t help.

I also found out about .trackerignore files via dconf, but adding that file to the directory my NFS shares are mounted in did not help. Do I need to actually put something in the file?

To top everything off, disabling my NFS mounts entirely did not help.

Finally, a recent power outage gave me cause to restart. Directly after restarting, Nautilus was starting instantly. Now, a day or so later, it’s starting slowly.

Could you give me some tips on how to further troubleshoot this? My search results have hit their limit.

I’m running Pop!_OS 20.04, so Nautilus 3.36.3-stable.

Thanks in advance!

Did you do a pkill nautilus ( which is needed to reload nautilus process ). Closing all nautilus windows doesn’t help here.

Just tried it, it didn’t seem to help.

I had been waiting long enough between starts that ps aux | grep nautilus wouldn’t show any nautilus processes.

Also, something I forgot to mention, is that if I leave the window open, new windows start up just fine. Though, apparently, save dialogs are just as slow…

When restarting, were the NFS mounts still disabled?
Were NFS mounts enabled when it got slow again?

The open/save dialogs being affected suggests me the problem is in either GTK or GIO/GVfs.

I think “NFS inside home” is a special case somehow. If you set your mountpoints to under /mnt/ and create symbolic links in your home folder to the mount points, does it improve anything?

Nope, I had finished with that test before the restart. So they up and running when I opened Nautilus again.

Yes.

I’ll try that and find out.