Monitor idle delay settings

Hello everyone,

I was wondering if it was possible to modify (or add) other values of the idle delay black monitor settings . By default these values are 1,2,3,4,5,8,10,12,15 minutes or “never”.

They can be changed through the item “energy” or “privacy” in settings.
They can also be changed with the line command:

gsettings set org.gnome.desktop.session idle-delay [here the desired value]

But how to change (or add) the set values of default?

Thanks for any answers!
Have a nice day!

You would need to modify the code here:

and here:

Thanks for the reply!

Unfortunately I am not able in writing code.
In the specific case I use gnome-control-center (version 43.4) within a distribution (Debian 12 - still testing) and I think (like you wrote) I should recompile and reinstall the same … 43.4

I thought there was a easier way to do it.

Thanks anyway!

What options do you think are missing that you’d like to add?

I personally think that there’s too many “small” options (does it really need all of 1, 2, 3, 4, 5?) and not enough “big” options - the addition of 30 minute and 1 hour options would be useful to me.

1 Like

I think exactly the same thing you wrote!
It would be better to have more uniformly distributed times.
For example something like that:

1,3,5,8,10,15,20,25,30 and then “never” (removing 2,4,12)
or, even better, a box in which to manually insert a value

Maybe there is some extension that can do this job?

Among other things, I noticed a small bug that afflicts almost all the versions of gnome-control-center. This bug (?) started (I think) from the version 43 (of Debian 12 for example). Certainly also present in the latest version 44 of gnome-control-center (present in Fedora 38, for example).

This happens (seeing is believing) : if an idle-delay value is set in this way for 20 minutes:

gsettings set org.gnome.desktop.session idle-delay 1200

If you return to the Settings and Energy menu, the value is set to “Never”.
Even if everything works. I think it’s a bug.

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.