Missing flatkpak(?) dependency using Builder

Hi

I created a Gnome Builder C project with meson as a build system. I successfully added and used some dependencies in meson.build as needed (namely libxxhash,sndfile,libpulse-simple) but now i need to add rubberband. On my system install, rubberband is known by pkg-config as “rubberband”, but Gnome Builder build system can seem to find it anywhere, saying:

[...]
Run-time dependency rubberband found: NO (tried pkgconfig and cmake)
../../../../../../../../../src/gnome-builder/Projets/my-project/src/meson.build:15:2: ERROR: Dependency "rubberband" not found, tried pkgconfig and cmake
[...]

what can I do ?

I found the answer.

The unpackaged flatpak library must be added as a module in the flatpak x.y.z.json file at the root of the project. I choose to import a tagged rubberband version and got lucky this library build system is well made and did not need any added setup.

{
"id":"x.y.z"

...

"modules": [
        {
            "name": "rubberband",
            "buildsystem": "meson",
            "sources": [
                {
                    "type": "archive",
                    "url": "https://github.com/breakfastquay/rubberband/archive/refs/tags/v3.3.0.zip",
                    "sha256": "b93fc7c02f40798095a80b44ee86ab988465288f88ba0e34835e048cc51dd866"
                }
            ]
        },
        {
           ... my  project source files module ...
        }
}

Then I was able to use rubberband as a dependency in my sources meson.build