Many apps on Wayland + Nvidia 545 are invisible

Many apps on Wayland with the Nvidia 545 drivers are invisible. This includes electron apps, some steam games etc.

System details:

# System Details Report

## Report details
- **Date generated:**                              2024-02-22 18:03:58

## Hardware Information:
- **Hardware Model:**                              ASUSTeK COMPUTER INC. PRIME B450-PLUS
- **Memory:**                                      16.0 GiB
- **Processor:**                                   AMD Ryzen™ 5 3600 × 12
- **Graphics:**                                    NVIDIA GeForce RTX™ 3060
- **Disk Capacity:**                               4.3 TB

## Software Information:
- **Firmware Version:**                            4401
- **OS Name:**                                     Arch Linux
- **OS Build:**                                    rolling
- **OS Type:**                                     64-bit
- **GNOME Version:**                               45.4
- **Windowing System:**                            Wayland
- **Kernel Version:**                              Linux 6.7.5-arch1-1

Any help is appreciated!



I was able to fix most electron apps by adding
--enable-features=UseOzonePlatform --ozone-platform-hint=auto (Works for apps like discord so far) (Note that you won’t have window decorations. But it strangely does have decorations when launching it as an app with a shortcut created with PinApp)

Currently having the same problem. The problem is not with wayland, but with XWayland. This is why @Kick_de_Gans “fix” solved it. He just forced wayland for electron apps, so they wouldn’t use XWayland.

Running on same setup except kernel version being 6.7.6-arch1-1

Tried with and without kms hook in mkinitcpio, tried with and without nvidia modules in mkinitcpio. None of the combinations work. nvidia_drm.modeset=1 is set as a kernel parameter and NVreg_PreserveVideoMemoryAllocations=1 module parameter is also set.
Systemd services nvidia-suspend, nvidia-hibernate and nvidia-resume are all enabled.

EDIT: Very interesting thing is that steam (despite running through XWayland) does work, but basically any electron app doesn’t. Neither does OpenRGB.

On Arch, reinstalling nvidia-utils will trigger something to fix this issue temporarily. (Perhaps this is fixed in 550 entirely.)

I will try that later today

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.