Magnifier issues

Hello everyone, I have a vision problem that the glasses don’t solve and I use a magnifier, but in Gnome it is unpossible because it shakes especially with the terminal, plus it does not have a mouse scrolll zooming feature. Please take a look at macOS, KDE or Cinamon’s magnifier which works properly. I’m wainting fix for it already 3 years from each update but still it’s unusable. (

You may have enabled caret tracking:

You can change the tracking here; you probably want to either keep the magnifier cursor centered.

That’s a feature request that has been opened for a while, but nobody has had time to implement it. It would be great if somebody picked it up.

My config

  1. Full screen mode
  2. Track mouse pointer

It shaking even mouse is disabled.

I’m a programmer and can try to fix this, I just found magnifier.c in the GTK repository but I’m not sure if it’s the correct Gnome magnifier repository.

Thanks for answer!

No, the magnifier in GTK has nothing to do with the magnifier in GNOME.

The magnifier in GNOME Shell is part of the GNOME Shell repository.

The feature request to enable zooming with the scroll wheel is in the GNOME Control Center repository.

This only changes the mouse tracking, so it won’t help with the magnifier moving due to caret events. There doesn’t seem to be a GUI option to adjust caret tracking, but something like gsettings set org.gnome.desktop.a11y.magnifier caret-tracking none should work (or push instead of none if you still want it to follow the caret when it would be out of screen). Similarly there is also focus-tracking for tracking focused widgets (which can be triggered by both mouse and keyboard navigation).