Limited contact autocomplete in Evolution

I’ve been struggling with this issue for weeks and can’t sort it out.

I’m using Evolution 3.46.4-2 on the latest version of Debian Bookworm (12.1) and, while composing an email message, the autocomplete feature only presents one option. The problem appears on my desktop computer but the dropdown autocompetion selection menu appears just find on my laptop running the same version of Debian with the same local addressbooks and the same configuration for autocompletion.

I believe that the problem first appeared when I upgraded from the previous version of Debian 11 and from X11 to Wayland. I thought Wayland was to blame until I started using Wayland on my laptop, too, without a problem.

I have also tried the flatpak version of Evolution (with fresh config and cache) where the same problem appears. Starting the application from the command line, no error messages appear while it’s running or when the autocomplete problem appears.

Any pointers that could help me resolve this issue?

do you mean there is shown only one auto-completed address, even there
are more hits in the same or more address books? Could it be only a
visual glitch, the height of the completion popup being too small ,
showing only one item, while there are more lines, which you can scroll
up/down for example with a mouse wheel? Being it a visual glitch, it
would be related to gtk3 itself. For example for me, when there is only
one hit, the popdown has a height for 3 lines, not only for one.

You mentioned the two machines are basically identical, including auto-
complete settings, from which I understand there are set the same books
with the same content for the completion in the


Hi, Milan!

Thanks for taking the time to reply.

Yes, the same address books are installed in both systems and I don’t think it’s a visual glitch. Even though more than one result is expected, the top result is automatically completed. If I continue typing, the required result eventually appears. Using the arrow keys to move up/down an invisible popup, does nothing either.

My guess was also that there is a problem with gtk and some incompatibility. I had installed some kde and qt-dependent applications. I uninstalled them just to check if that would make a difference but to no avail. My second guess is that libgtk3:i386, which is also installed to support wine, might be the culprit here (as it is not installed on my laptop) but I wouldn’t like to uninstall too much and break my system at this point.

As this problem doesn’t seem to ring a bell to anybody else, I will do more testing around Christmas when I won’t be needing a reliable system that desperately. If I can’t find what’s wrong, I’ll just reinstall everything, making sure I record the effect of every package I install.

If I continue typing, the required result eventually appears.


in that case, I’m only guessing, it can be it takes more time to the
respective book to provide all matches. Maybe.

I had installed some kde and qt-dependent applications…
libgtk3:i386, …

Those have no impact on the Evolution. Do not waste your time on trying
to uninstall them.

If we agree it’s not a visual glitch, then it can be a setting of the
book, causing it to provide the matches possibly too slowly or some
such thing.


This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.