Known good mailserver is rejected by Geary

I have a problem where a known good mailserver address is incorrectly labelled as inaccessible by Geary in the account setup dialog.

I was able to successfully add my account in Thunderbird, so I believe it is a Geary issue
Specifically, it was This is my University’s mailserver.

I don’t know the exact setup of the server but I know there is a MS Exchange server somewhere in the system. The ports they requested I connect to were 993 (incoming) and 587 (outgoing). Are these nonstandard ports that Geary can’t connect to?

Also, the validation seemed very flimsy. Occasionally, the red boxes would turn white upon re-entry of the server, and I managed to click the confirm button once, which caused Geary to crash.

Here is the result of dig MX:

; <<>> DiG 9.18.6 <<>> MX
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 63350
;; flags: qr rd ra; QUERY: 1, ANSWER: 3, AUTHORITY: 0, ADDITIONAL: 1

; EDNS: version: 0, flags:; udp: 65494
;		IN	MX

;; ANSWER SECTION:	600	IN	MX	10	600	IN	MX	10	600	IN	MX	10

;; Query time: 284 msec
;; WHEN: Wed Sep 14 18:25:26 CEST 2022
;; MSG SIZE  rcvd: 123

Pinging these addresses shows they’re alive.

Port 993 is generally IMAP, not Exchange

Yes, I am adding this server as an IMAP server. I also did that in Thunderbird and it works. I don’t need Exchange functionality. I was adding this information in case this is a known incompatibility with the server software.

How did you add this Exchange account in Geary? Manually as a generic provider?

What happens if you add a Microsoft Exchange account in GNOME Online Account? (enable Mail)

I didn’t add an Exchange Account to Geary, I just added an IMAP server where I know it is ultimately based on an Exchange system.

To my knowledge it shouldn’t really matter that it’s an Exchange-based system in the background.

To be very specific, this is the error I’m receiving that I know I shouldn’t be receiving.


You can find more information on Geary tracker and maybe open a new issue if you can’t find anything similar.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.