Keyboard switching between workspaces randomly does not work

I’d like to switch between workspaces with Meta+{1…9} I’ve tried to set this up and working in two different ways, but neither seem to work properly. What happens is that some of the keyboard shortcuts works but some does not.

I’ve tried the following:

$ for i in {1..9}; do gsettings set "org.gnome.desktop.wm.keybindings" "switch-to-workspace-$i" "['<Super>$i']" ; done as described here: Reddit - Dive into anything

With this one only Meta+{1…5} are working. Weird.

I’ve also tried using the Space Bars extension, that comes with an option to use Meta+{1…9}. With this one, it seems that Meta+{1…4} always works, but after that that it is completely random which works. Sometimes they all work, sometimes a couple of them does not work. A few minutes later the ones that just did work, does not work while the ones that did not work suddenly work.

Any suggestions as how to approach this error?

I found this, which seem to be the solution: keyboard shortcuts - Super+1, Super+2, Super+3, etc. keys can not be remapped in Gnome - Unix & Linux Stack Exchange


Upgrading to fedora 39 with Gnome 45.1 broke my switch-to-workspace shortcuts as well.

I have the same setting than yours:

gsettings set "org.gnome.desktop.wm.keybindings" "switch-to-workspace-$i" "['<Super>$i']"

My switch-to-application-$i are all set to [], so it doesn’t seem like a conflict with them.

What I’ve found is that when the focus is in a text field (this very one, a terminal, an editor, …), switching to desktop 2, 7, 9 or 10 doesn’t work and print the character in the focused field instead. In french layout 2, 7, 9, 0 are é, è, ç, à.

When there’s no text field in focus, the shortcut works correctly.

Setting the shortcuts to ['<super>é'] doesn’t work obviously.

Any suggestion?

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.