Keyboard shortcut really slow after update

After an update in june/july keyboard shortcut became really slow (and gdm doesn’t work any more).
I use wayland on Arch.

Could you help me to solve please?
tnks.

If you want someone to respond to your questions, try providing more specific information.

I don’t know gnome architetture and how It manage shortcut.
I’d like to know where to found useful log and manage debug.

Anyway, one thing is sure, gdm3 doesn’t start any more after the same system update (I have to disabile that service).

Ask for any info you need to understand the issue, please.

Thanks you for your time.

Is the delay around 30 seconds? If so that could indicate some dbus problem, probably some service timing out or dbus not started properly. How do you start gnome?

Yes… It is around 30 seconds…
I start gnome without gdm service because after and update of Arch on june/july I have this problem with shortcut and gdm3 doesn’t start.

I’d love you of you can help me to debug and solve these issues!!!

I can share below “journalctl -u gdm” output of a boot, I think the two are related.

Thanks.

– Boot 862f63cdcc5a4e3c9912a16d1cf4cdfc –
set 05 10:08:41 ArchLinux systemd[1]: Starting GNOME Display Manager…
set 05 10:08:41 ArchLinux systemd[1]: Started GNOME Display Manager.
set 05 10:08:41 ArchLinux gdm[729]: Gdm: Enabling debugging
set 05 10:08:41 ArchLinux gdm[729]: Gdm: Changing user:group to gdm:gdm
set 05 10:08:41 ArchLinux gdm[729]: GLib-GIO: Using cross-namespace
EXTERNAL authentication (this will deadlock if server is GDBus < 2.73.3)
set 05 10:08:41 ArchLinux gdm[729]: Gdm: Successfully connected to D-Bus
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmManager: GDM starting to
manage displays
set 05 10:08:41 ArchLinux gdm[729]: Gdm: Could not ping plymouth:
Esecuzione del processo figlio «plymouth» non riuscita (File o directory
non esistente)
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmLocalDisplayFactory:
enumerating seats from logind
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmLocalDisplayFactory: display
for seat seat0 requested
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmLocalDisplayFactory:
Checking if udev has settled enough to support graphics.
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmLocalDisplayFactory: Found
primary PCI graphics adapter, proceeding.
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmLocalDisplayFactory: udev
has settled enough for graphics.
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmLocalDisplayFactory: System
supports graphics
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmLocalDisplayFactory: Getting
session type (prefers wayland, falling back: no)
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmLocalDisplayFactory: New
displays on seat0 will use wayland
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmLocalDisplayFactory: wayland
login display for seat seat0 requested
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmLocalDisplayFactory: Adding
display on seat seat0
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmDisplay: id: (null)
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmDisplay: seat id: (null)
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmDisplay: session class: greeter
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmDisplay: initial: no
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmDisplay: allow timed login: yes
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmDisplay: local: yes
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmDisplay: supported session
types: (null)
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmDisplay: session type: wayland
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmDisplay: supported session
types: wayland:x11
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmDisplay: seat id: seat0
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmDisplay: initial: yes
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmDisplayStore: Adding display
/org/gnome/DisplayManager/Displays/94233665124736 to store
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmDisplay: Managing display:
/org/gnome/DisplayManager/Displays/94233665124736
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmDisplay: Preparing display:
/org/gnome/DisplayManager/Displays/94233665124736
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmDisplay: Checking kernel
command buffer BOOT_IMAGE=/vmlinuz-linux
root=UUID=268ca439-a0f8-4522-a90a-1ef31d8560a4 rw loglevel=3
resume=/dev/nvme0n1p6
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmDisplay: Failed to read
kernel commandline: Could not match gnome.initial-setup= in kernel cmdline
set 05 10:08:41 ArchLinux gdm[729]: Gdm: doing initial setup? no
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmDisplay: prepare display
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmDisplay: Got automatic login
details for display: 0
set 05 10:08:41 ArchLinux gdm[729]: GdmDBusUtils: Registered DBus error
domain ‘gdm-session-worker-error-quark’
set 05 10:08:41 ArchLinux gdm[729]: GLib: setenv()/putenv() are not
thread-safe and should not be used after threads are created
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmSession: Creating D-Bus
server for worker for session
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmSession: D-Bus server for
workers listening on unix:path=/tmp/dbus-fkgv1tkJ
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmSession: Creating D-Bus
server for greeters and such for session (null) (0x55b47c240210)
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmSession: D-Bus server for
greeters listening on unix:path=/tmp/dbus-onS0JSXP
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmSession: Setting display
device: (null)
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmSession: Created user
session for user 120 on display
/org/gnome/DisplayManager/Displays/94233665124736 (seat seat0)
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmDisplay: Running greeter
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmDisplay: Creating greeter
for (null) (null)
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmLaunchEnvironment: Starting…
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmLaunchEnvironment: Setting
up run time dir /run/gdm/greeter
set 05 10:08:41 ArchLinux gdm[729]: GLib: setenv()/putenv() are not
thread-safe and should not be used after threads are created
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmSession: Creating D-Bus
server for worker for session
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmSession: D-Bus server for
workers listening on unix:path=/tmp/dbus-rGyBYlXE
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmSession: Creating D-Bus
server for greeters and such for session (null) (0x55b47c246770)
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmSession: D-Bus server for
greeters listening on unix:path=/tmp/dbus-dkvSXvJL
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmSession: Setting display
device: (null)
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmSession: starting
conversation gdm-launch-environment for session (0x55b47c246770)
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmSessionWorkerJob: Starting
worker…
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmSessionWorkerJob: Running
session_worker_job process: gdm-session-worker
[pam/gdm-launch-environment] /usr/lib/gdm-session-worker
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmSessionWorkerJob: :
SessionWorkerJob on pid 773
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmSession: setting session to
type ‘wayland’
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmLocalDisplayFactory: display
status changed: 1
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmLocalDisplayFactory:
received VT change event
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmLocalDisplayFactory: VT is 1
at startup
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm: Enabling
debugging
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: connecting to address: unix:path=/tmp/dbus-rGyBYlXE
set 05 10:08:41 ArchLinux gdm[729]: GdmDBusServer: new connection
0x7f6138000b70
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmSession: Handling new
connection from worker
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmSession: Authenticating new
connection
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmSession: worker connection
is 0x7f6138000b70
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmSession: Emitting
conversation-started signal
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmSession: Beginning
initialization
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmSession: Conversation started
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: attempting to change state to SETUP_COMPLETE
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: initializing PAM; service=gdm-launch-environment
username=gdm seat=seat0
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: Set PAM environment variable: ‘XDG_SEAT=seat0’
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: Set PAM environment variable: ‘XDG_SESSION_CLASS=greeter’
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: state SETUP_COMPLETE
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: attempting to change state to AUTHENTICATED
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: authenticating user gdm
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: state AUTHENTICATED
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: attempting to change state to AUTHORIZED
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: determining if authenticated user (password
required:0) is authorized to session
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: state AUTHORIZED
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: attempting to change state to ACCREDITED
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: Set PAM environment variable: ‘LOGNAME=gdm’
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: Set PAM environment variable: ‘USER=gdm’
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: Set PAM environment variable: ‘USERNAME=gdm’
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: Set PAM environment variable: ‘HOME=/var/lib/gdm’
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: Set PAM environment variable: ‘PWD=/var/lib/gdm’
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: Set PAM environment variable: ‘SHELL=/usr/bin/nologin’
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: Set PAM environment variable:
‘PATH=/usr/local/bin:/usr/local/sbin:/usr/bin’
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: state ACCREDITED
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmSession: type wayland,
program? yes, seat seat0
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: session display mode set to new-vt
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: Set PAM environment variable: ‘XDG_SESSION_TYPE=wayland’
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: attempting to change state to ACCOUNT_DETAILS_SAVED
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: saving account details for user gdm
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: attempting to change state to SESSION_OPENED
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: Set PAM environment variable: ‘XDG_VTNR=1’
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: state SESSION_OPENED
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmSession: Emitting
‘session-opened’ signal
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmDisplay: Greeter session opened
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmDisplay: session id: 1
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmSession: Stopping all
conversations except for gdm-launch-environment
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmSession: type wayland,
program? yes, seat seat0
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmSession: getting session
command for file ‘gnome.desktop’
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmSession: ‘gnome.desktop’
registers self
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmSession: type wayland,
program? yes, seat seat0
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: Set PAM environment variable: ‘DCONF_PROFILE=gdm’
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: Set PAM environment variable:
‘GDM_SUPPORTED_SESSION_TYPES=wayland:x11’
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: Set PAM environment variable: ‘GIO_USE_VFS=local’
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: Set PAM environment variable: ‘USER=gdm’
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: Set PAM environment variable: ‘SHELL=/usr/bin/nologin’
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: Set PAM environment variable:
‘GVFS_REMOTE_VOLUME_MONITOR_IGNORE=1’
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: Set PAM environment variable: ‘USERNAME=gdm’
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: Set PAM environment variable: ‘LOGNAME=gdm’
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: Set PAM environment variable: ‘PWD=/var/lib/gdm’
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: Set PAM environment variable:
‘XDG_DATA_DIRS=/usr/share/gdm/greeter:/usr/share:/var/lib/flatpak/exports/share:/usr/local/share/:/usr/share/’
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: Set PAM environment variable: ‘LANG=it_IT.UTF-8’
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: Set PAM environment variable: ‘GDM_SEAT_ID=seat0’
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: Set PAM environment variable: ‘RUNNING_UNDER_GDM=true’
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: Set PAM environment variable: ‘HOME=/var/lib/gdm’
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: Set PAM environment variable: ‘GDM_VERSION=44.1’
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: Set PAM environment variable:
‘XDG_CURRENT_DESKTOP=GNOME-Greeter:GNOME’
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: Set PAM environment variable:
‘GNOME_SHELL_SESSION_MODE=gdm’
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: Set PAM environment variable: ‘GDM_LANG=it_IT.UTF-8’
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: Set PAM environment variable:
‘PATH=/usr/local/sbin:/usr/local/bin:/usr/bin’
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: Set PAM environment variable: ‘GVFS_DISABLE_FUSE=1’
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: start program: /usr/lib/gdm-wayland-session
“dbus-run-session – gnome-session --autostart
/usr/share/gdm/greeter/autostart --debug”
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: attempting to change state to SESSION_STARTED
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: opening session for program ‘/usr/lib/gdm-wayland-session’
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: jumping to VT 1
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: first setting graphics mode to prevent flicker
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: VT mode did need to be fixed
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: session opened creating reply…
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm:
GdmSessionWorker: state SESSION_STARTED
set 05 10:08:41 ArchLinux gdm-launch-environment][773]: Gdm: GdmSession
worker: watching pid 794
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmSession: Emitting
‘session-started’ signal with pid ‘794’
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmDisplay: Greeter started
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmManager: trying to register
new display
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmCommon: Found session 1 for
PID 794, using
set 05 10:08:41 ArchLinux gdm[729]: Gdm: GdmLocalDisplayFactory: display
status changed: 2
set 05 10:09:08 ArchLinux gdm[729]: Gdm: GdmCommon: Found session 1 for
PID 811, using
set 05 10:09:08 ArchLinux gdm[729]: Gdm: GdmManager: trying to register
new session on display 0x55b47c22b980
set 05 10:09:08 ArchLinux gdm[729]: Gdm: GdmDisplay: session registered: yes
set 05 10:09:08 ArchLinux gdm[729]: Gdm: GdmLocalDisplayFactory: session
registered on display, looking for any background displays to kill
set 05 10:09:23 ArchLinux gdm[729]: Gdm: GdmLocalDisplayFactory:
received VT change event
set 05 10:09:23 ArchLinux gdm[729]: Gdm: GdmLocalDisplayFactory: VT
changed from 1 to 2
set 05 10:09:23 ArchLinux gdm[729]: Gdm: GdmLocalDisplayFactory: VT of
login window is 1
set 05 10:09:23 ArchLinux gdm[729]: Gdm: GdmLocalDisplayFactory: VT
switched from login window
set 05 10:09:23 ArchLinux gdm[729]: Gdm: GdmLocalDisplayFactory: killing
login window once its unused
set 05 10:09:23 ArchLinux gdm[729]: Gdm: GdmLocalDisplayFactory: display
status changed: 3
set 05 10:09:23 ArchLinux gdm[729]: Gdm: GdmLocalDisplayFactory: active
VT is not initial VT, so ignoring

How exactly do you start it?

As gdm service is disabled, After boot I have to insert user and password by console and the gnome start automatically.

Tell me what I have to check for your Better understanding.

and the gnome start automatically.

That is not how this would normally work and is probably something you set up yourself. Maybe you modified your profile or bashrc to do that?

Absolutly no.
Just gdm.service disabled (because since the same update gdm and shortcut calls have problems).

If gnome autostarts after you logged in on a TTY, then there is definitely something strange going on, but that’s not something on the gnome side. Maybe it would be better to ask on your distro’s forum.

I tryed to start gdm in Automatic Login mode (adding AutomaticLoginEnable=true AutomaticLogin=user in /etc/gdm/custom.conf ) and in that way gnome start with gdm without any problem and system is fluid.

Indeed, a related problem was keybord shortcuts delayed on gnome which I normally (no AutoLogin) can start only after gdm disabling.

Why?

Could you help me to look into?

I need gdm with several user and so I’m just partially solved.

Thanks.

So the problem why the shortcuts were slow was indeed due to how gnome was started. Likely not starting dbus or some dbus services correctly, which is something gdm would take care of doing properly.

That still does not explain the misconfiguration that causes gnome to get autostarted when logging in on a TTY even with gdm disabled. Whatever this misconfiguration is, it might also interfere with gdm itself.

I run Arch Linux.

Is that not a normal configuration on Arch?

If not where can I try to check?