Keyboard-map related issue: hyper key not working in gsettings for "org.gnome.desktop.wm.keybindings *window/app*"

Hello all,

Having used Ubuntu/Debian on servers I’m now migrating from OS X to Ubuntu Desktop. I’ve found it fairly hard to adjust my muscle memory, and have thus delved into the depth of the keyboard settings. (Some notes on the journal and tools built here: https://github.com/bjohas/Ubuntu-keyboard-map-like-OS-X/tree/master)

This issue is about the hyper key not working in gsettings for “org.gnome.desktop.wm.keybindings window/app

I have set up a Hyper key on the keyboard. It works fine for keyboard shortcuts and seems to be ok when checked with xev. However, applying these gsettings doesn’t work:

org.gnome.desktop.wm.keybindings switch-windows ['<Hyper>Tab']
org.gnome.desktop.wm.keybindings switch-windows-backward ['<Hyper><Shift>Tab']

i.e. running this command

gsettings set org.gnome.desktop.wm.keybindings switch-windows "['<Hyper>Tab']"

does allow me to switch windows with Hyper-Tab. Same when using Hyper for switch-applications and cycle-windows - that also doesn’t work. However Hyper works - as said above - for other keyboard shortcuts, such as Hyper+a, etc.

Also, when Super or Alt is used (to assign e.g. Super+Tab), all combinations work as expected.

What does Hyper not work? Is this a bug in gnome or an issue with another system component?

(Ubuntu 19.04)

Also posted here: https://askubuntu.com/questions/1188046/setting-gnome-window-switching-to-hyper-doesnt-work, which has a link to this issue on the bug tracker, in case it’s a bug.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.