Items Not Displaying Correctly in GNOME Apps

Hello,

I am experiencing a display issue with the GNOME desktop environment. In several GNOME applications, such as Settings, File Manager, Software, and Extensions Manager, the items do not show up initially. However, when I hover over them, their names appear.

Interestingly, this issue does not occur when I snap the window or when the window is in full screen mode.

System Information:

  • Desktop Environment: GNOME
  • Graphics Card: NVIDIA GT 710
  • Graphics Driver: 470xx

Issue Description:

  • When I open any GNOME application (Settings, File Manager, Software, Extensions Manager), the items within the application window are initially blank.
  • Upon hovering over the blank items, their names and icons appear.
  • This issue does not occur when the window is snapped or in full screen mode.

Steps Taken to Troubleshoot:

  1. Updated System: Ensured all packages are up to date.
  2. Changed Theme: Switched to different themes in GNOME Tweaks with no improvement.
  3. Reset GNOME Settings: Used dconf reset -f /org/gnome/ to reset GNOME settings to default.
  4. Checked Graphics Drivers: Verified and updated graphics drivers (using NVIDIA 470xx drivers).
  5. Disabled Fractional Scaling: Set scaling to 100% in Display settings.
  6. Disabled GNOME Extensions: Disabled all extensions via GNOME Tweaks and Extensions app.

Additional Information:

  • I have encountered this issue on multiple Linux distributions, including Fedora, Ubuntu, and Arch Linux.

Despite these efforts, the issue persists. I would appreciate any guidance or suggestions on how to resolve this display problem. Has anyone else encountered a similar issue, or is there something I might be missing?

This seems to be a bug when using the Nvidia driver 470 (and older?) in combination with the new gtk renderer:

I have exactly the same issue - NVIDIA 470xx packages and a GeForce GT710. Files in particular shows blank text which appears as you pass the mouse over it. I HAD hoped there was a tweak I could apply to fix it… I am running Fedora 40.

See the first comment in the linked issue.

My bad. Workaround perfect. Thanks.