Interface modification of gnome-software

After opening the ui file in gnome-software, some controls cannot be displayed after opening my glade. Is there a solution?
Is it because some controls are not recognized because of the version of glade? If so, can you provide the installation package, thank you

  1. What version of glade do you use ?

  2. Did you try the gnome-nightly flatpak ?

  3. You can attach a screenshot of the ui file in glade, describing the issue, if '[2]' did not work.

Thanks!

1.Glade is 3.18, and I also tried the latest version. I can’t find the installation package for the old version.
2.I haven’t tried it yet. If I want to modify the ui interface classification layout of gnome-software, which package should I modify?
3.


There are many things like this I can’t view and modify

This is because Glade is only really able to display widgets coming from the catalogs (webkitgtk, gtk, libhandy, etc.), but it isn’t aware of the widgets defined in the project’s code, like all the Gs* widget from Software (here it’s your GsOverviewPage that doesn’t work). I don’t think there’s a way to make that work out… (but maybe there is ?)

2 Likes

@Cola_liu: you should get in touch with gnome-software developers, to know how they update their ui files.

Also, please use a recent version of glade, whenever possible. Recent versions ( 3.38+ ) have fixed a lot of issues which will make working with glade easier.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.