Inkscape SVG files are not displayed correctly

I don’t know if this problem is related to Fedora Silverblue 34, librsvg or due to Inkscape but the drawings that I made in Inkscape aren’t displayed correctly anymore after the reinstall of Silverblue.

This how my cv should look like:
[Removed image showing document with text]

But this is how it looks now:
[Removed image showing document with some text missing]

Anybody an idea what the problem could be?

Blind guess: missing fonts ?

Is the incorrect rendering being produced from Inkscape? If so, it’s probably Inkscape’s problem or one of its dependencies.

Or are you using EOG, or rsvg-convert? If so, it’s probably librsvg’s problem.

The incorrectly rendered image looks too big to be one of the thumbnails that Nautilus produces, but if the thumbnails are incorrect, it could also be librsvg’s problem.

I just found out that’s due to the font Montserrat.

It’s installed by default (on the base image of Fedora Silverblue) but Inkscape doesn’t display the font correctly:

Screenshot from 2021-05-04 22-26-51

In Inkscape:

  • When I write a new piece of text and apply the Montserrat font to it, the text disappears.
  • When I replace the font Montserrat with Cairo (Inkscape -> Extensions -> Replace font), all text becomes visible again (so the text is present).

The font is displayed correctly in LibreOffice, so I think the problem is Inkscape?
Or librsvg? Or the software that renders the fonts?

Summary of the problems
 
 
Problem 1
The font below aren’t displayed correctly in Inkscape (1.0.2) and Gimp (2.10.24).

  • Montserrat Light
  • Montserrat Normal
  • Montserrat Bold
  • Montserrat Ultra-Bold

When I write a piece of text in Inkscape and apply one of the above fonts, the text disappears. The text stays present because when I change the font again, the text reappears.

The fonts are displayed correctly in LibreOffice and Firefox.

 
 
Problem 2
Thumbnails in GNOME Files that use those fonts aren’t generated properly.
Screenshot from 2021-05-05 20-04-32

 
 
Questions
Where shall I report these two bugs?
Which library is the wrongdoer :slight_smile: ?

As a temporary solution I replaced the font Montserrat with the font Raleway (they more or less look similar).

The font Raleway looks good in Inkscape but the thumbnails in GNOME files are still not generated correctly. Not even after applying the command touch -m *

Does somebody know which software / library is responsible for displaying the fonts in Inkscape and GIMP?
And which software is responsible for generating the thumbnails?

Does somebody know which software / library is responsible for displaying the fonts in Inkscape and GIMP?

That’s Pango (and FontConfig for font discovery)

And which software is responsible for generating the thumbnails?

Not so sure to be honest, but I guess it’s Tracker?

Try running pango-view and check if Pango is able to render the Montserrat font.

@lb90: Thanks for the information!

Instead of pango-view (which only gave me errors) I tried Font Manager. This is what I get:

So something goes wrong :laughing:! But what?

1 Like

As a last test, could you try running hb-view? E.g:

hb-view --output-file=render.png /path/to/Montserrat.ttf "Lorem ipsum dolor sit amet consectetuer..."

Hi lb90,
 
Thanks for helping me debugging this problem!
 

This is what I did:

  1. Created and entered a new toolbox.
  2. Downloaded and compiled HarfBuzz.
  3. Run the command hb-view --output-file=render.png Montserrat-Regular.ttf “Lorem ipsum”
     
     

Result:

 
 
This way the font Montserrat-Regular.ttf is displayed correctly :smiley: !
What can we conclude from this?

Ok, then you can open an issue in Pango GitLab :wink:

1 Like

Thanks, I will do that!!

I’ve installed that font, and it works just fine in gtk3 and gtk4 applications here.

Did you also use Fedora Silverblue 34?

On the project page of Pango (on gitlab.gnome.org) I created the following issue:
https://gitlab.gnome.org/GNOME/pango/-/issues/559