Iio-sensor-proxy does not rotate screen on 2-in-1 device using Wayland

Hello,

I have been trying to debug an issue about screen rotation on my 2-in-1 device. Some more information is here

I have so far tested this device on:

  • Manjaro Stable(5.10 kernel and GNOME 40.1.0)
  • Fedora 34(5.12 kernel and GNOME 40 too)

I ran most of the debug steps in the iio-sensor-proxy gitlab site as well.

  1. Manjaro Stable (Wayland) didn’t work at all because iio-sensor-proxy wasn’t installed and even after installing it, it starts and shuts down by itself
  2. Fedora 34 has iio-sensor-proxy installed and when I run monitor-sensor, the sensor is picking up that I am rotating the device, but the screen doesn’t rotate
  3. I also tested screen autorotate extension on Fedora 34. I followed the steps exactly to add the extension, then logged out and tried to log back in but I was constantly taken back to the login screen
  4. I also tried to run xrandr -o 1(is this only supported on X11? see below *) in Wayland on both Manjaro and Fedora and this didn’t rotate the screen

I want to keep debugging the issue because Wayland is the future of most desktops, but I wanted to see if the device might work on X11. Alas! It actually worked! I didn’t need to do much at all and *running xrandr -o 1 or xrandr -o 2 changed the orientation of the screen exactly how I would want it.

I can’t tell if the bug is in Wayland or iio-sensor-proxy, but I am starting by reporting it here so that maybe the bug can be resolved. It isn’t distro-specific because I am testing this on both Fedora and Manjaro and neither works to rotate the screen.