Icons not showing for new documents in context menu

I just installed Ubuntu 22.10. I put several empty LibreOffice and text documents in the Templates folder. All separately created using the various LibreOffice apps and a text editor. This worked and I can now create various New Documents by right clicking in a folder / using the context menu. However, the New Document types in the context menu do not have icons, they would be faster to select if they did. Can I enable these icons somewhere? / Is this a bug? The icons do show appropriately in the Templates folder itself.

Ubuntu 22.10, Gnome 43.1.

Already tried asking on AskUbuntu but no reply: gnome - icons for templates Ubuntu 22.10 - Ask Ubuntu
Tried Gnome Bug report on Gitlab but was closed for being the wrong place to post: Icons not showing for new documents in context menu (#6399) · Issues · GNOME / gnome-shell · GitLab

This is by design. You can submit a feature request on the Files’ GitLab if you would like for this menu to have icons.

It’s not a bug, per se: menus don’t have icons as general rule.

The “create file from template” UI is bound to change in the future, though, to not use a menu.

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.