Icon for Firefox parallel instance .desktop file does not show in dock when running

I run multiple Firefox instances in order to have an app that just contains my Nextcloud calendar (like a electron style app for one purpose). I have a custom calendar.desktop file for that. That all used to work fine and then Ubuntu changed to snap Firefox. After some fiddling it worked but now on a recent update I see a gears icon in the dock when I run the app instead of getting a dot next to the icon and when alt-tabbing I don’t see the custom icon (though it shows up for the app when not launched). Using looking glass I looked at the gtk_application_id and it is null or in the window list.

Here is the .desktop file:

[Desktop Entry]
Comment=Firefox just for calendar
Exec=env BAMF_DESKTOP_FILE_HINT=/var/lib/snapd/desktop/applications/firefox+parallel_firefox.desktop /snap/bin/firefox_parallel %u -P Calendar -no-remote --new-window https://calendar.example.com --name calendar --class calendar
GenericName=Web Browser duplicate

And here is the instructions on getting parallel instances of firefox to work with snap:

It seems related to this thread:

Any help would be very welcome.

The wm-class property is more relevant here, the gtk_application_id is only used as a fallback and I don’t think Firefox sets or uses it. If those don’t match the file name of the .desktop file or the StartupWMClass, then gnome-shell won’t be able to associate the windows with the app. Setting this is the responsibility of the client, so maybe a Firefox specific support forum might be able to help you better with this.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.