How to configure + connect to the new headless gnome-remote-desktop service?

Hi! I see that Gnome 46 is adding support for a single-user headless login via RDP. Excellent! I’ve bumped a testing VM to Fedora 40-beta and pulled in a beta build of Gnome 46. I’ve enabled the gnome-remote-desktop service:

systemctl enable --user --now gnome-remote-desktop

I tried connecting with an RDP client on port 3389, but nothing is currently listening. Is there any documentation for this functionality yet? I’ve been looking at Adapt the Remote Desktop panel for headless sessions (being able to configure the g-r-d system daemon) (#2827) · Issues · GNOME / Settings · GitLab but I don’t see what I’m missing.

3 Likes

I suppose that the main problem is the fact that the gnome-remote-deskop Fedora package hasn’t been updated to version 46 yet.

3 Likes

@dkasak If you’re wanting to test RDP in gnome46 before it is out on Fedora40, you can use gnome-os 46.rc - just note that if you’re trying to run the gnome-os installation image you need to use edit the VM’s config’s tag content for secure boot as follows before starting with the https://os.gnome.org/download/latest/gnome_os_installer.iso image:

  <os firmware="efi">
    <type arch="x86_64" machine="pc-q35-8.1">hvm</type>
    <firmware>
      <feature enabled="no" name="enrolled-keys"/>
      <feature enabled="no" name="secure-boot"/>
    </firmware>
    <loader readonly="yes" type="pflash">/usr/share/edk2/ovmf/OVMF_CODE.fd</loader>
    <nvram template="/usr/share/edk2/ovmf/OVMF_VARS.fd">/var/lib/libvirt/qemu/nvram/gnome46_VARS.fd</nvram>
    <bootmenu enable="yes"/>
  </os>

Also you will need to use sudo eos-updater-ctl update to update to the latest OS tree release and ignore “Desktop Sharing” and click “Remote Login”


note the username can be anything, it seems as it simply establishes a secure connection using the RDP protocol - you shall arrive at the login screen and select your user. It will bump the logged in session off when you attach.

1 Like

When I get to this dialog, Login Details and Port are greyed out and I cannot make these settings persist. I am running gnome 46.

The Fedora 40 Beta with the latest updates has the gnome-remote-deskop v46. However it does not work for me. I get past RDP authentication, then a black screen for few seconds, then disconnects.

try setting selinux to permissive mode (it doesn’t have policy yet).

see 2271661 – gnome-remote-desktop system login feature is disallowed in enforcing mode

2 Likes

Thank you Ray for the tip. It works now with selinux in permissive mode.

can you help me

i use gnome 46 on arch linux

Enabled remote login but encounter a black screen upon connection

1 Like

The same on the Fedora 40 (Black screen)

I’m using Fedora 40 Beta.

I’ve activated remote log in in GNOME settings
I’ve set setenforce 0
Still, when I log on using Windows RDP I get prompted for username/password, but then rightly after the session closes.

Anyone found a workaround?

Am also facing the same issue - with latest updates. XRDP works perfectly fine and desktop sharing too. Only remote desktop has this issue.

I thought I had set setenforce 0 but clearly not. I found this guide and it worked.

Basically: sudo nano /etc/selinux/config
Change: selinux=enforcing to selinux=permissive

That did it work me. No more black screen.

1 Like

SELinux is complex and controversial. Many Linux distributions do not support SELinux at all, such as archlinux. The solution discussed above turns out to be to modify the settings of Gnome’s non-essential dependencies. Or make it clear that GDM remote login must require SELinux.

The reason for the black screen seems to be related to the computer not supporting tpm2.0.

Anyone else here running into a 0x207 error code when they try to connect from the Microsoft Remote Desktop app for macOS?

I tried the setenforce 0 command and it helped with the 0x4 error code, but I’m stuck here.

That didn’t work unfortunately… I even updated the /etc/selinux/config file and reset my machine, but that didn’t fix the issue

$ sestatus
SELinux status:                 enabled
SELinuxfs mount:                /sys/fs/selinux
SELinux root directory:         /etc/selinux
Loaded policy name:             targeted
Current mode:                   permissive
Mode from config file:          permissive
Policy MLS status:              enabled
Policy deny_unknown status:     allowed
Memory protection checking:     actual (secure)
Max kernel policy version:      33

I don’t know if this is normal, but I noticed that I kept getting asked for a username and password. I did set a username and password before, but I got rid of it.

Ubuntu 24.04 Gnome 46 black screen

I just installed Fedora Silverblue, did my system updates and rebooted, enabled both settings for remote desktop in the System config panel, and when I try to connect from another machine, I get this:

Also, connecting by hostname gives a DNS error, even though from the same Linux machine I am able to use hostname to remote to a Windows machine.