How to configure a non-Wacom graphics tablet?

I’ve a USB graphics tablet, XP-Pen G430. I can’t find any way to configure the area mapping (or anything for that matter). The default is to map the whole area to the entirety of my 2 monitors; I need to map a smaller rectangle to a single monitor.

I’m on Fedora 33 (GNOME 3.38), using Wayland. I’m able to configure the area fine on e.g. sway.

1 Like

Hi Ivan,

Did your tablet work to your expectations before, and it is not working now in GNOME 3.38,

- or -

Is this your first attempt of getting your tablet to work in GNOME / Linux ?


It’s my first attempt to get it to work on GNOME specifically. I used it before fine on sway (and even earlier than that on an X setup without a DE).

Can you switch from GNOME Wayland to GNOME X11 in login screen, and see if it works there to establish a baseline here.


What am I supposed to see working? The tablet works on Wayland already, it’s just mapped with its full area to both of my monitors, and I don’t see anywhere I can set up the mapping, which is what I’m asking about.

What I meant by “earlier on an X setup without a DE” is that on X I could configure the tablet in the Xorg config file. I suppose I could do that on GNOME X11 too, but I’d like to use the tablet on GNOME Wayland specifically. might help.

My tablet is not a Wacom tablet and it’s not detected by the Wacom menu in Settings. That’s the problem I’m talking about.

I’ve not used any graphics tablets, so not an expert here.

But, why would you expect a non-Wacom tablet to be detected in Wacom Tablet menu in settings ?

Some help page:


I do not expect it detected in Wacom Tablet menu settings. I’m asking if there’s any other place (e.g. some dconf key) I can configure my tablet in an absence of general tablet menu settings.

I got a suggestion in #gnome-shell to make a libwacom .tablet file for my tablet, which I did, and now I can configure it from the Wacom Tablet settings menu.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.