[How] Question - Backlight device selection


I’m using GNOME Wayland on my laptop which (unfortunately) has NVIDIA discrete graphics - Lenovo 15ARH05H.

The problem is that when I’m using hybrid graphics mode, I get 2 backlight devices:

$ ls /sys/class/backlight
amdgpu_bl0   <-- The correct one
nvidia_0     <-- Currently used but not working

By default, Mutter uses nvidia_0 backlight device which isn’t working. Backlight control works only on the first amdgpu_bl0 device which also drives the display.

The problem disappears when the discrete GPU is disabled there is only 1 backlight control device.

I tried to play with different acpi_backlight values but it didn’t help. Then, I tried to find a way to disable the broken backlight control in NVIDIA driver, but NVIDIA removed that option a long time ago (nvidia.NVreg_EnableBacklightHandler=0 and others).

My question: is it possible to explicitly tell Mutter which backlight device it should use to control the backlight?

Many thanks :pray:

Hi, there is currently not a way to manually pick the backlight device. And it should not be necessary to do so for hybrid graphics since this gnome-settings-daemon commit.

It might make sense to report a gnome-settings-daemon issue so we can figure out why that automatic detection of the active connector doesn’t work for your case.

1 Like

Thank you for the suggestion, @garnacho. I created an issue here, hope someone will take a look at it.

Closing the thread as discussion moved to GitLab issue