How can I re-enable the Xorg option in GDM?

Hello! I recently upgraded my buddy’s PC to Fedora 39. I didn’t realize that the new version already disabled signing in with the Xorg session (only available for Classic). Of course, as he is an Nvidia user, his desktop was completely glitching out on Wayland, with windows flickering and being totally unstable. He also really didn’t like Classic. So, I downgraded him back to Fedora 38. Unfortunately, the hidden Xorg option stuck, meaning he has no way of logging in to his desktop to play games. How can I re-show the “GNOME on Xorg” option for him on Fedora 38? Please send help!

That would be a bug, please ask or file an issue in the fedora forums.

You can try switching the session like this:
How to switch between Wayland and Xorg without the cogwheel at login? - #3 by vgaetera
Then relogin to apply the changes.

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.