Hello ! I’m a complete beginner and I wanted to create an application with GTK in Rust. I tried to compile a blank project with the
gtk4 package as a dependency and I got the following error :
Package dependency requirement 'glib-2.0 >= 2.66' could not be satisfied. Package 'glib-2.0' has version '2.64.6', required version is '>= 2.66'
I’m on Rocky Linux 8 (so pretty much centOS) so I tried
sudo yum install glib2-devel
But it still did not give me a recent enought version.
I tried grabbing one from here : RPM resource glib2-devel
But it complained about dependency requirements it could not meet (which makes sense, the most recent version of glib2-devel probably depends on the most recent version of other things, and those probably won’t be in the repos I have as well).
I also tried the gtk4 and gtk4-devel packages from the raven repo.
Any advice ? Thanks in advance !