Help or fn1 does not work in epiphany

This is a highly customized Gentoo desktop machine, no display manager, just a simple X server and twm (The Window Manager) managing gui programs.

When accessing “Help” from the menu section or just pressing the fn1 key an error message pops up (tried to attach screenshot, but could not upload the file because I’m a new user):

Could not show link
The specified location is not supported

This is not a serious issue but still, is it abug? I have the latest version of web installed with default configuration with some changes in Preferences section. Everything else works and I’m happy with this software.

Respectfully submitted,

Tried strace, but no clue. Searched various web sites and got an idea: maybe fn1 is trying to activate “yelp” software. So I installed it, and bingo: fn1 or Help works now!

My suggestion - and I don’t know what is the proper channel for this:
(1) include a comment, or better yet, check if yelp is installed, in the menu screen “Help” entry and instead of the error message display something like"Install yelp package for Help functionality".
(2) Also include a similar comment in the project web site web - epiphany, Download or Install section that yelp package needs to be installed for full functionality of epiphany web browser.


This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.