Help, Gnome crashing

I need help troubleshooting constant Gnome crashes on a fresh install. Im kinda hoping for some quick and dirty tips/tricks.

Fedora 33 Workstation (tried Silverblue first, and got same error before swapping to Workstation)
Thinkpad P50 with discrete Nvidia Quadro M2000M
Using with external display.

I have tried both Wayland and Xorg, but I see similar issues.

Just a few minutes into logging into the desktop, the are constant shudders/lag with mouse and keyboard input. A few minutes later, there the whole desktop will lockup: sometimes mouse is still usable, but the application windows/shell are locked up. I will usually see a flickering triangle in the top left of external monitor.

I can switch to a TTY, but I haven’t been successful restarting GDM. I typically have to reboot laptop.

In journalctl, I see:

Feb 04 13:14:19 usphable-lin kernel: i915 0000:00:02.0: [drm] Resetting rcs0 for preemption time out
Feb 04 13:14:19 usphable-lin kernel: i915 0000:00:02.0: [drm] gnome-shell[1783] context reset due to GPU hang
Feb 04 13:14:19 usphable-lin kernel: i915 0000:00:02.0: [drm] GPU HANG: ecode 9:1:85dffffb, in gnome-shell [1783]
Feb 04 13:14:19 usphable-lin kernel: GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
Feb 04 13:14:19 usphable-lin kernel: Please file a new bug report at https://gitlab.freedesktop.org/drm/intel/issues/new.
Feb 04 13:14:19 usphable-lin kernel: Please see https://gitlab.freedesktop.org/drm/intel/-/wikis/How-to-file-i915-bugs for details.
Feb 04 13:14:19 usphable-lin kernel: drm/i915 developers can then reassign to the right component if it’s not a kernel issue.
Feb 04 13:14:19 usphable-lin kernel: The GPU crash dump is required to analyze GPU hangs, so please always attach it.
Feb 04 13:14:19 usphable-lin kernel: GPU crash dump saved to /sys/class/drm/card0/error

Contents of /sys/class/drm/card0/error

I found a setting in the Lenovo bios. I changed graphics mode from “Switchable Graphics” to “Discrete Only”. This has resolved all the “GPU Hang” issues.

It’s a shame that the hybrid graphics are not working, but this workaround should be sufficient for others who encounter this issue.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.