Headless Remote Desktop setup process


I’m trying to setup Gnome Remote Desktop 46 in headless mode on WSL 2 OpenSUSE Tumbleweed. I’ve installed gnome-remote-desktop from the community package repository home:ohollmann:staging:openssl which has specifically version 46.0 . And it said that the package is installed successfully.

Prior to that I’ve also installed gnome-shell 46.0 from Tumbleweed standard repository and it remains installed in my system (if it matters) but it seems to come without gnome-remote-desktop.

I have no access to any GUI on this system and I want to setup gnome remote desktop in headless mode and see how hard it is to setup in this way.

I have ssh access to the system (mostly following this guide: SSH into a WSL2 host remotely and reliably | by Gilad Lekner | Medium) and I’m able to port forward ports through ssh. But when I’m trying to connect to 3389 I get channel 3: open failed: connect failed: Temporary failure in name resolution. I’ve chosen to use ssh to avoid changing ports either in gnome-remote-desktop or in Windows and wonder if it is the source of any additional problems, but in case of success I may prefer to make rdp directly accessible through local network alongside ssh in a long run.

I’m still getting gnome-remote-desktop: command not found, but I’ve tried to start gnome-remote-desktop with sudo systemctl enable gnome-remote-desktop at it seemed to have worked but when I’m checking sudo systemctl status gnome-remote-desktop I’m getting

gnome-remote-desktop.service - GNOME Remote Desktop
     Loaded: loaded (/usr/lib/systemd/system/gnome-remote-desktop.service; enabled; preset: disabled)
     Active: active (running) since <timestamp>; 50min ago
   Main PID: 127 (gnome-remote-de)
      Tasks: 4 (limit: 4915)
     CGroup: /system.slice/gnome-remote-desktop.service
             └─127 /usr/libexec/gnome-remote-desktop-daemon --system
systemd[1]: Starting GNOME Remote Desktop...
gnome-remote-de[127]: Init TPM credentials failed because No TPM device found, using GK>
systemd[1]: Started GNOME Remote Desktop.

Unlike in Fedora 40, Tumbleweed seems to have no selinux installed so it isn’t the source of my problem.

May somebody help me setting up gnome-remote-desktop through CLI?

This is how it works on Fedora 40:

# Server
sudo dnf -y install gnome-remote-desktop freerdp
sudo -u gnome-remote-desktop winpr-makecert \
    -silent -rdp -path ~gnome-remote-desktop rdp-tls
sudo grdctl --system rdp enable
sudo grdctl --system rdp set-credentials "${RDP_USER}" "${RDP_PASS}"
sudo grdctl --system rdp set-tls-key ~gnome-remote-desktop/rdp-tls.key
sudo grdctl --system rdp set-tls-cert ~gnome-remote-desktop/rdp-tls.crt
sudo systemctl --now enable gnome-remote-desktop.service
sudo firewall-cmd --permanent --add-service=rdp
sudo firewall-cmd --reload

# Client
sudo dnf -y install gnome-connections
gnome-connections rdp://host

Permissive SELinux policy:
Gnome Remote Desktop with SELinux enforced - #9 by vgaetera - Fedora Discussion

Another related thread:
How to configure + connect to the new headless gnome-remote-desktop service?

1 Like

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.