Hard to get rid of Alt+F1 keyboard shortcut

I use GNOME Shell 41.4, Alt+F1 opens “Applications” menu. I couldn’t find this shortcut in Keyboard Shortcuts UI, eventually I found dconf-editor path /org/gnome/desktop/wm/keybindings/panel-main-menu where it was set to Alt+F1 but it’s marked as DEPRECATED and indeed, clearing it there has no effect, Alt+F1 still opens “Applications” menu.

I eventually found dconf-editor path /org/gnome/shell/extensions/apps-menu/apps-menu-toggle-menu with ['<Alt>F1'] and clearing it did the trick.

Similarly gsettings works:

gsettings set org.gnome.shell.extensions.apps-menu apps-menu-toggle-menu "[]"

I spent total about one hour trying to figure out how to disable Alt+F1 shortcut in GNOME, because shortcut is not surfaced in normal Keyboard Shortcuts UI and because Google points to panel-main-menu which is still there, still defaults to Alt+F1 but is now deprecated (doesn’t say deprecated by what) and clearing panel-main-menu has no effect.

  • Is it possible to surface Alt+F1 in Keyboard Shortcuts UI?
  • Is it possible to mention /org/gnome/shell/extensions/apps-menu/apps-menu-toggle-menu in the panel-main-menu DEPRECATED message?

P.S. Added gnome - How can I disable the Alt + F1 and Alt + F2 shortcuts? - Ask Ubuntu, hopefully it’ll help someone save an hour of life :slight_smile:

Since it is an extension setting, there are a lot of ways to go about it.

If you do not need the applications menu, just disable the extension.

If you do need the extension, just open the Extensions app and click on the gear icon right next to ‘Applications Menu’ extension. There should be an option to change or disable the shortcut.

No. Settings picks up shortcuts from a system directory (/usr/share/gnome-control-center/keybindings), while extensions are generally installed inside the user’s home (and contained in a single directory).