GtkFileDialog.save_finish()

I’m using FileDialog.save so the app user can create a new database. It works OK (I think!) except whilst using Builder to run the project FileDialog attempts to save to a directory it doesn’t have permission… /run/user/1000/doc/7712ccc0/test.sqlite3… in this case.

I’m guessing that’s normal if it hasn’t been installed on the system as a .flatpak but is there a workaround I can use while I’m building and testing?

Thank you!

Is there no way around Builder not being able to access my Home directories? I can’t test simple things like reading and writing to a database. I managed to get it installed as a flatpak app and it’s still the same… /run/user/1000/…

I tried getting my Builder project to work in VSCode but that isn’t easy either.

The problem is not Builder, or the file selection dialog: the document portal does not support sqlite3 files. See, for reference: xdg-desktop-portal#1117.

Thank you for replying. I didn’t expect it to be Builder or FileDialog, rather Flatpak. I just gave Flatpak full access to my filesystem and my app is now working fine. That’s obviously not good (!) so I’ll have to come back to it later. No doubt it’s possible to change what’s available to individual Flatpak installs upon install. I’m only using FileDialog to get a path.

Thank you for the link. There’s lots to read there including a link all about sqlite and temp files. I should have a good read of that too.