GtkEntry cannot put an accent marks on

Hi guys,

Seems that new GtkEntry widgets (latest stable gtk4 release 4.8.0) cannot put accent marks on letters. Is there a bug ?

(For example: when trying to write [á] or [à], the widget shows simply an [a]).

Notice that the same happens also in all demos (gtk4-demo) that implement GtkEntry widgets (Completion, Undo and Redo, Password Entry, Search Entry…)

Hi! Which system / distro are you using?

I’m using Debian GNU/Linux (current stable 11.5, with some packages in testing) but gtk4 / gtkmm-4.0 packages are build & installed from sources using Meson.

1 Like

I see the same issue with text entry in all GTK4 apps. I’m on Arch Linux with gtk 4.8.0. Downgrading to 4.6.7 fixes the issue.

I have US keyboard layout without dead keys, with Right Ctrl set as my compose key. In any GTK4 app if I type <right ctrl>+<'> then <a> it should input <á> but it inputs <'a> as if I didn’t press the compose key.

For example this happens in the new Text Editor, Characters and GTK Demo.

Edit: I just updated all my flatpaks and tried Text Editor from Gnome Nightly. According to its /usr/manifest.json that also has gtk 4.8.0. But the compose key works fine in that.

Might be useful to know which IME module is in use, both in Debian / Arch Linux and Flatpak. To get that, either:

  • Run gtk4-demo, open the hamburger menu, then open the GTK inspector. Switch to the General tab and look for IME.
  • Open a terminal and run a GTK4 application as GTK_DEBUG=interactive application. This will launch the app with the GTK inspector open. Go to the General tab and look for IME

On my Arch Linux install it shows: gtk-im-context-simple.

With native GTK4 app I have this issue but not with the same app from gnome-nightly flatpak, which also has gtk 4.8.0. But the input method for the flatpak is also gtk-im-context-simple.

Looking at the gtk commits I see that yesterday Matthias Clasen did this MR https://gitlab.gnome.org/GNOME/gtk/-/merge_requests/5026. That is post the 4.8.0 release. But if I understand the issue it solves, that is to fix a problem with Arabic keyboards under X11. I’m using a US keyboard under Wayland. Maybe it’s related.

1 Like

gtk-im-context-simple, in my case also.

1 Like

Thank you both! I’m out of ideas, so I think you can open an issue in https://gitlab.gnome.org/GNOME/gtk/-/issues

Whoever comes first wins :smiley:

I also tried on Fedora 37 beta. My copy of it has an older gtk4 (4.7.something) but I noticed the input method was ‘wayland’. So I ran gsettings reset org.gnome.desktop.interface gtk-im-module on Arch Linux to reset my input method setting and now it is wayland when I check in a GTK4 app with inspector. But the issue is still present :expressionless:

Anyway, just to add that it doesn’t look to be related to input method ‘gtk-im-context-simple’.

Edit: upgraded my Fedora 37 beta and now have gtk4 4.8.0. The issue doesn’t happen on that. I’m going to report this to Arch Linux first.

By looking at recent issues I stumbled upon https://gitlab.gnome.org/GNOME/gtk/-/issues/5133, which looks like what’s reported yhere.

It’s been fixed by https://gitlab.gnome.org/GNOME/gtk/-/merge_requests/5012, maybe this should be backported in Arch Linux

This issue is probably fixed by https://gitlab.gnome.org/GNOME/gtk/-/merge_requests/5012. Can you update your local git checkout, rebuild and test if you can still reproduce?

5026 has nothing to do with dead keys. 5012 does.

Thanks you @lb90 for the suggestion & @matthiasc for confirmation, building 4.8.0 with 5012 applied solves the issue.

Solved also for me. Thanks.