GTK theme on windows ignored

Hello,

I’ve just cross compiled a gtk-rs project to an exe and I’d like to configure theme for it.

I followed the instruction on GTK Project, put the theme css under share/themes/{theme name}/gtk-3.0 and the settings.ini under etc/gtk-3.0 (I also tried etc/gtk-4.0), but it just didn’t pick up the theme.

Is there any suggestion how I can debug this to see if this is a gtk configuration problem or something related to gtk-rs?

Thanks.

You need to use GTK settings and set gtk-theme-name setting property to win32. Make sure you check platform before doing this btw.

I haven’t used GTK in rust, here’s the GTK docs. For gtk3 replace 4 in this url with 3.

Hi,

I actually found out the problem. It picked up the settings.ini alright, but it was the theme that caused the problem.

I should’ve put the theme under gtk-4.0.