GStreamer tutorials and Wayland

This is a low priority question.

Recently we got two requests from someone who tries to convert the basic-tutorial-3.c to Nim. As I tried to help him, I first tried to compile and run the C example. I took the latest code from

examples/tutorials/basic-tutorial-3.c · master · GStreamer / gst-docs · GitLab

and did

gcc -Wall basic-tutorial-3.c -o basic-tutorial-3 pkg-config --cflags --libs gstreamer-1.0

Pipeline state changed from NULL to READY:
basic-tutorial-3: …/wayland-1.20.0/src/wayland-client.c:2312: wl_proxy_set_queue: Assertion `proxy->display == queue->display’ failed.
Aborted (core dumped)

The strange thing is, that basic-tutorial-1 fails now also:

$ ./basic-tutorial-1
basic-tutorial-1: …/wayland-1.20.0/src/wayland-client.c:2312: wl_proxy_set_queue: Assertion `proxy->display == queue->display’ failed.
Aborted (core dumped)

While basic-tutorial-1 was working well maybe one year ago – we had even a working Nim version of that one.

As the error message is wayland related, I tried to log out and in again with X11 Gnome session, and then the programs seems to work.

My wayland is the one shipped with Gentoo Linux. Maybe I got some updates in the last 12 months. Google has unfortunately no idea about the error message.


That looks like either a problem in your system’s setup or a bug in some GStreamer element. Please report this here and include a full debug log with GST_DEBUG=6 in the issue.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.