GNOME40/FedoraRawhide: Wayland command line to control/delay screen blanking

First post ever - please be patient with noob :slight_smile:

I am using MPLAYER to watch TV through a Hauppauge TV tuner
Is there any way for a normal non-programmer to disable or reset the timer, or change the screen blanking delay to more than 15 minutes?. (setting not on tweaks, or dconf-editor)
Right now every 15 minutes the screen goes blank while watching TV - annoying
Problem not happening on Firefox - how do they do it?

Thank you in advance.

1 Like

You can either run mplayer through gnome-session-inhibit:

$ gnome-session-inhibit mplayer // mplayer args go here

Or run it separately in a terminal:

$ gnome-session-inhibit --inhibit-only

In the first case, screen blanking is inhibited as long as mplayer is running, in the second case you have to terminate the command manually with CtrlC to re-enable screen blanking again.

3 Likes

Install Caffeine (Gnome Extension) to prevent this from happening.

try this

gsettings set org.gnome.desktop.session idle-delay 0

it turns off screen blanking