Gnome web (Epiphany) crashes while watching videos

When I click play to watch a video in gnome web I get this


I get a lot of this kind of stuff

nouveau: 0x00047ac0
nouveau: 0x7e200000
nouveau: 0x000c6900
nouveau: 0x20000008
nouveau: 0x00000000
nouveau: 0x00c1a000
nouveau: 0x00087080
nouveau: 0x00000000
nouveau: 0x00c1a01f
nouveau: 0x000475dc

and in between

nouveau: ch8: psh 00000000 0000038680 000003905c

and

nouveau: kernel rejected pushbuf: Invalid argument
nouveau: ch8: krec 0 pushes 1 bufs 25 relocs 0
nouveau: ch8: buf 00000000 00000004 00000004 00000004 00000000
nouveau: ch8: buf 00000001 00000007 00000002 00000002 00000000
nouveau: ch8: buf 00000002 0000000a 00000002 00000002 00000000
nouveau: ch8: buf 00000003 0000000a 00000002 00000002 00000000
nouveau: ch8: buf 00000004 0000000b 00000002 00000002 00000000
nouveau: ch8: buf 00000005 00000008 00000002 00000002 00000000
nouveau: ch8: buf 00000006 00000008 00000002 00000002 00000000
nouveau: ch8: buf 00000007 00000006 00000004 00000000 00000004
nouveau: ch8: buf 00000008 00000006 00000004 00000000 00000004
nouveau: ch8: buf 00000009 00000029 00000002 00000000 00000002
nouveau: ch8: buf 0000000a 00000034 00000002 00000000 00000002

Sometimes it does not crash but the video plays really wierdly , like some coloured rectangles here and there on the video with lots of flickering of the whole web page
using 5.8 kernel on pureos byzantium (based on debian testing) in gnome wayland

1 Like

Please file a bug at:

https://gitlab.gnome.org/GNOME/epiphany/-/issues

An issue has been filed here:
https://gitlab.gnome.org/GNOME/epiphany/-/issues/1364

3 Likes

I am new to stack trace . I got something like this.
Reading symbols from /usr/bin/epiphany…
(No debugging symbols found in /usr/bin/epiphany)
I had used this command to find the debug symbols for epiphany.
find-dbgsym-packages /usr/bin/epiphany
and it asked me to install the following packages:
lib32stdc++6-10-dbg libkrb5-dbg libpcre3-dbg libstdc++6-10-dbg libx32stdc++6-10-dbg libxdmcp6-dbg
which I did.

I cannot attach the pdf file here as I am a new user so I should attach what I got with the bug report. Please do suggest If I need to do anything more (like install new packages).