Gnome-wayland cursor gets ~1.2x bigger when hovering over glfw window

glfw program source code (at the bottom of the page of):
https://www.glfw.org/docs/latest/quick.html
bad-glfw2

the bug occurs only in gnome wayland, gnome x11 and sway wm cursor works as expected
(display scaling not enabled)

edit: GNOME Shell 43.9

On Fedora, glfw isn’t built with wayland support. Building it from git with wayland enabled, I see the opposite problem: the cursor is tiny, except for the titlebar provided by libdecor which has the correct size.

I see similar behavior in weston, so this is probably a glfw bug:

1 Like

did you build glfw version 3.3.9 with wayland enabled and you still get tiny cursor
it worked perfectly for me

actually it might be because of some missing glfw package, rather than enabling wayland support, i vaguely remember i installing libglfw-something package and not only did it fix the cursor issue, it also added window decorations

compiling with wayland flag, only made the window more performant/smoother