Gnome OS ISO doesn't boot

Tried the following:

  • gnome_os_installer.iso
  • gnome_os_installer_40.beta.iso

on

  • Virtualbox ( with EFI )
  • GNOME Boxes 3.38.2-stable
  • GNOME Boxes nightly flathub

Probably, I am missing something.

Thanks!

1 Like

Boxes from Flathub certainly works. And I just tried the latest iso works too, and certainly the beta iso works as well.

Any logs or errors?

$ md5sum gnome_os_installer*

180176cc32e5c950ebe163e90d2807d6  gnome_os_installer_40.beta.iso
cb0ab1537911b4d400670c7f21bd4d40  gnome_os_installer.iso

Error in BoxesDevel:

qemu-system-x86_64: -device ide-cd,bus=ide.1,unit=0,drive=libvirt-1-format,id=ide0-1-0,bootindex=1: Failed to lock byte 100
shutting down, reason=failed

Thanks!

And sometimes, when it gets past the above error, boot halts at the following screen:

1 Like

This error happens when you try to use install from an iso that isn’t in your home directory. Please copy it to your home directory (you can delete the iso once it is installed).

You can also run Boxes as flatpak run --filesystem=/where/the/iso/is/ org.gnome.Boxes if you don’t want to copy.

2 Likes

Well that didn’t work for me.

Neither did the following:

$ flatpak run --user --filesystem=/vms/ org.gnome.BoxesDevel
machine.vala:644: Failed to start GNOME OS Nightly 4: Unable to start domain: internal error: process exited while connecting to monitor: 2021-03-01T05:23:11.183453Z qemu-system-x86_64: -device ide-cd,bus=ide.2,drive=libvirt-1-format,id=sata0-0-2,bootindex=1: Failed to lock byte 100

Not sure why.

The following worked though:

$ flatpak override --user --filesystem=/vms/ org.gnome.BoxesDevel
$ flatpak override --user --show org.gnome.BoxesDevel
[Context]
filesystems=/vms;
$ flatpak run org.gnome.BoxesDevel

Current status:

Both 'gnome_os_installer.iso' and 'gnome_os_installer_40.beta.iso' work in Boxes nightly flatpak.

Both ISOs fail to boot in Boxes 3.38.2-stable

Some quick debugging revealed that this might be due to EFI permission related issues, as below:

This issue is tracked here.

Thanks!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.