Gnome keyboard shortcuts keep changing by themself

As the title suggests, my keyboard shortcuts keep changing themselves in gnome. I always set win+1 to take you to first desktop, win+2 to take you to the second, and win+3 to take you to the third. Every time I reboot win+2 now opens a file manager and I have to go into the keyboard shortcuts, delete the current win+2 assignment for desktop change, and then re-enable it and save. It does not actually change the settings in the gnome keyboard shortcuts program. They still look fine and it’s still set to change desktops, but it just opens file manager instead until I do the aforementioned. I have searched google many times for this and I seem to be the only one experiencing this. Any suggestions would be appreciated.


No, that’s not what is happening.

The keybindings you set up are already used for the switch-to-application-n shortcuts, which activate the n-th favorite application from the dash.

If the same keybinding is set up for two conflicting shortcuts, whichever is grabbed first “wins”.

To fix the issue, unset the conflicting shortcuts:

$ for n in $(seq 1 9)
  gsettings set switch-to-application-$n '[]'

There are no other keys set to that shortcut. Yes, it does keep making this keybinding happen on it’s own after every reboot. It doesn’t even show win+2 as being assigned to anything else. I have even looked at the keyboard shortcuts within the file manager to see if there is one that summons it.

Settings doesn’t show the built-in super+1super+9 shortcuts. Although it should still warn about conflicts, unless you are using a fairly old GNOME version.

The place to look is the underlying GSetting:

$ gsettings get switch-to-application-1

Does that really come up empty?

This command shows super+1 and the others show super+2 and so on. Can I UNSET these? I am using gnome 3.38.5. Debian is way behind on updates unless you update to bookworm.

Yes. I told you the command to do it in the first response.

I didn’t use it because it had all the for/in statements in it. I was looking for the gsettings argument to pass to just unset the keybinding for “switch-to-application-2”. If I don’t understand the statements I don’t copy/paste them.

I just ran gsettings set switch-to-application-2 []

That’s very reasonable.

In case you’re interested, the command I posted runs the gsettings set ... command 9 times, with numbers from 1 to 9 in the variable $n.

Ohhh okay. I see it now that you’ve explained it. Thanks for your help!

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.