GNOME extensions greyed out in ""

Normally, in debian, I go to, and install “GNOME Shell integration” browser extension and install the needed extensions. But, in Fedora 38, even after installing the “GNOME Shell integration” browser extension, the extensions ON/OFF toggle button was disabled, as shown below:

I was confused as I’ve never seen this in Debian ( probably as extension support was enabled by default - afaik ). I then checked to see if extension support was enabled, by opening the “GNOME Extensions” app. It was not installed. I then installed it with

 # dnf install gnome-extensions-app.x86_64 

Opening the Extensions app confirmed that the extension support was disabled:

Enabling it caused the extensions ON/OFF toggle button to be enabled in the browser:

Possible Fix:

When the extensions support is disabled in GNOME Shell, there should be a message in the extension browser page indicating this, and point to a link with steps needed to get it enabled.


The toggle is also on the Extensions website, under Installed extensions:

I could perhaps be made more discoverable, or as you suggest the feedback on why extensions can’t be installed could be improved.

1 Like

Yeah, I just noticed it a while ago when trying to find my installed extensions, after the fix suggested in the original post. But, I very rarely access the “Installed extensions” Tab. Mostly, I just search for an extension and install it.

Also, I think “Shell settings” should not be in “Installed extensions” Tab. Perhaps there could be in a separate “Settings” Tab.

A better fix would be, to automatically display a info bar in the browser, asking whether the user wants to enable “Shell extensions”, similar to how the there is a prompt for installing the “GNOME Shell integration” browser extension, when is accessed.

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.