Gnome desktop is partially in english instead of all german


I am on EndeavourOS with the most recent gnome packages installed. Since a few days I have an issue with english language popping up which should not happen.

My user is set to german:

Everything is in german. The menues, the extension, everything. Except for the popup menu that I get when I do a right click on the desktop background:


This was not the case a few days ago. Something has changed and I do not know what. Along with this language topic I see a new behavior of the screenshot function (Print key). It now stores screenshots in
~/Bilder/screenshots. In the past it stored them in ~/Bilder/Bildschirmfotos.

Any idea what is wrong here?

That doesn’t help. Please always provide the version information.

Are you using any extensions?

My guess would be that some of them calls Gettext.textdomain(), which doesn’t just set the domain for the extension in question (as intended), but for the entire gnome-shell process.

Here is the list of all gnome packages installed

eos-settings-gnome 2-1
gnome-autoar 0.4.4-1
gnome-backgrounds 44.0-1
gnome-bluetooth 3.34.5-4
gnome-bluetooth-3.0 42.6-1
gnome-browser-connector 42.1-4
gnome-builder 44.2-5
gnome-calculator 44.0-1
gnome-calendar 44.1-1
gnome-characters 44.0-1
gnome-chess 43.2-1
gnome-clocks 44.0-1
gnome-code-assistance 3:3.16.1+r14+gaad6437-2
gnome-color-manager 3.36.0+r42+g90481514-1
gnome-console 44.4-1
gnome-contacts 44.0-1
gnome-control-center 44.4-1
gnome-desktop 1:44.0-1
gnome-desktop-4 1:44.0-1
gnome-desktop-common 1:44.0-1
gnome-devel-docs 40.3-1
gnome-disk-utility 45.0-1
gnome-font-viewer 44.0-1
gnome-icon-theme 3.12.0-7
gnome-icon-theme-symbolic 3.12.0-6
gnome-keyring 1:42.1-3
gnome-klotski 3.38.2-1
gnome-latex 3.44.0-1
gnome-logs 43.0-1
gnome-mahjongg 3.40.0-1
gnome-maps 44.4-1
gnome-menus 3.36.0-2
gnome-mines 40.1-1
gnome-multi-writer 3.35.90-1
gnome-music 1:44.0-2
gnome-nettool 42.0-2
gnome-nibbles 3.38.3-1
gnome-online-accounts 3.48.0-2
gnome-photos 1:44.0-3
gnome-power-manager 43.0-1
gnome-recipes 2.0.4-5
gnome-remote-desktop 44.2-1
gnome-robots 40.0-1
gnome-screenshot 41.0+r25+g45f08f0-1
gnome-session 44.0-1
gnome-settings-daemon 44.1-1
gnome-shell 1:44.4-1
gnome-shell-extension-dash-to-panel 56-3
gnome-shell-extension-vitals 61.0.0-1
gnome-shell-extensions 44.0-1
gnome-software 44.5-1
gnome-sound-recorder 42.0-2
gnome-sudoku 44.0-1
gnome-system-monitor 44.0-1
gnome-taquin 3.38.1+r35+g35edb95-1
gnome-terminal 3.48.2-1
gnome-tetravex 3.38.2-1
gnome-text-editor 44.0-2
gnome-themes-extra 3.28+r6+g45b1d457-1
gnome-tweaks 42beta+r14+g2d9d76c-3
gnome-usage 3.38.1-2
gnome-user-docs 44.3-1
gnome-video-effects 1:0.6.0-1
gnome-weather 44.0-1
libgnome-games-support 1.8.2-2
libgnomekbd 1:3.28.1-1
polkit-gnome 0.105-10
xdg-desktop-portal-gnome 44.2-1

That was actually it. When I deactivate extensions, the popup is back to german. Activating one extension after the other reveals that the Forge tiling extension is causing the issue. It is reproducable: enable/disable this extension and logout and login again.

Thank you for helping. I will have to file an issue with that Forge extension.

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.