Gnome default apps are greyed out under Settings

Hello, I installed very minimal Gnome shell and from there I progressed by installing necessary packages individually, this is because I love minimalistic setup which allows me to pick what I want installed on my computer. There’s 2 things that I miss currently

  • Gnome settings doesn’t allow you to change default apps and some are greyed out
  • Gnome device security is unavailable in settings.

Is someone aware which packages I am missing that need to be installed for this functionality to be present?

Gnome Version: 45.4
Windowing System: Wayland
OS: Arch Linux

Default Apps Screenshot

Device Security Screnshot

To resolve Gnome device security being unavailable in Arch linux, you need


command to install: sudo pacman -S fwupd

Still need help figuring out how to resolve default apps

Do you have any other apps installed that should appear there? The lists are populated by apps that advertise support for the appropriate mime type:

If there’s more than one candidate, you’ll see a dropdown.

I use LibreWolf, is there any way to check if this is supported? LibreWolf is based off Firefox with more privacy focus

I think you can check by running these, but I don’t want to go manual way of setting these. I wish to change it via Settings.

Anyway, here is command

Whenever clicking on Links it opens in Builder app. Here are the settings queried from my pc:

xdg-mime query default text/html


cat /usr/share/applications/mimeinfo.cache | grep librewolf


gio mime text/html

Default application for “text/html”: org.gnome.Builder.desktop
Registered applications:
Recommended applications:

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.