Gnome 42: Settings -> Appearance -> Dark Mode does not work

Hiya guys,

a few days ago I built Gnome 42 from scratch on Slackware -current. The most things work how they should. But, to switch from the light mode to the dark mode doesn’t work.

Is it possible to switch into dark mode by command line…that I can see what is wrong?


1 Like

You can use gsettings set org.gnome.desktop.interface color-scheme 'prefer-dark'.

1 Like

wallpaper follows light-dark from settings–>appearance.
but apps like console and gnome-text-editor can turn on light-dark only from their own menu. they dont follow dark theme from settings—>appearance because for some reason settings window it self dont turn to dark mode also!

gsettings set org.gnome.desktop.interface color-scheme 'prefer-dark'

run with out error message.
were do you think we should search for that problem?

ps. Gnome 42 is awesome! good job guys!!!

1 Like

apps like console and gnome-text-editor can turn on light-dark only from their own menu

That depends on the setting:

Screenshot from 2022-04-03 23-29-45

The first item means “follow the system default”, the other two “force light mode regardless of system preference” and “force dark mode regardless of system preference” respectively.

thank you for the answer, I know that , but my English are not so good…
what i mean is that “follow the system default” is not working for apps window
only wallpaper change to dark. Even the main window of settings dont turn to dark but command is given because wallpaper turn to dark mode!

Hi, did you tried this from a fresh new user? Maybe, there is som previous custom configuration in your user that prevents this to works properly.

You can also see your logs or journal, to see if it is something related when you change the dark mode on.

A couple of dependencies were misssing, the scripts are UpToDate. :blush:
The binaries are online shortly.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.