GLSL shader for the whole screen does not work anymore


I created an extension to apply a GLSL shader to the whole screen, to compensate color offsets in my projector. I used add_effect_with_name() and Main.uiGroup was the actor. However, this does not work anymore (at least with 3.36). Can anybody give a hint if there where any changes that I should adopt my extension to, and how this can be done?

There weren’t any intentional changes, and

Main.uiGroup.effect = new Clutter.DesaturateEffect()

works as expected here (on 3.38-ish).

1 Like

Thanks. I don’t know what exactly I did wrong. As my extension was a bit crappy anyway, I took an existing extension (Tint All), removed the funny color stuff and replaced it with my shader effect (via add_effect_with_name()). Now I even have a top bar button to enable and disable the shader which will also reload the shader file.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.