GIMP unresponsive and very slow to start

GIMP 2.10.32 took about 30 minutes to start and did not run well an Windows 10, though it had run fine before. GIMP must be constantly accessing the network on startup because when I connected to my work VPN from home (I had installed GIMP at work, while on the our network at work) it worked MUCH better and faster. GIMP only took ~30 seconds to start after connecting to the VPN.
I think GIMP SHOULD NOT access the network so much on startup, but that is just my opinion.

GIMP must be constantly accessing the network on startup because when I connected to my work VPN from home (I had installed GIMP at work, while on the our network at work) it worked MUCH better and faster. GIMP only took ~30 seconds to start after connecting to the VPN.
I think GIMP SHOULD NOT access the network so much on startup, but that is just my opinion.

GIMP does certainly not access the network “constantly”, or at least, if it does, it is definitely a bug. What GIMP does is:

  • It access this json file to know if new versions (or revision package of currently running version) was made available. For info, this is a read-only access, no info sent, and we don’t keep or process even common HTTP data (which would be in the HTTP server logs), as per our Privacy Policy. The sole purpose is for people to be warned of new versions (and to have less outdated GIMP, with vulnerabilities, in the wild).
  • This access is done in a separate thread for non-blocking the main process. So it is absolutely not supposed to block GIMP startup (i.e. that even if connection fails, blocks, times out or anything else, it’s just totally in the background and the rest of the startup continues its life). If really it does, we need more info.
  • This access is done at most once a week, and certainly not at every startup (except on development builds, because in there we want to discover bugs as fast as possible; but on stable builds, there is a flag set so that GIMP doesn’t retry for at least a week).
  • Lastly you can disable the check for updates in Edit > Preferences > System Resources, switch OFF the “Check for updates” setting. By the way, in the environment where GIMP apparently always gets stuck, I would suggest to try and switching this option OFF, then verify if suddenly GIMP is fast on the next startup. It may help diagnose if it is really related.

In any case, GIMP does not “constantly” access the network, this is for sure. It’s only a startup thing, not even at every startup, and it should not be blocking. If things are different for you, could you give us a bit more info? What makes you think it is absolutely network related? Did you try changing the network settings from one to the other multiple times and each time you could reproduce the problem?

Also 30 min is definitely not normal, and even 30 secs, I find this long. There used to be long startup issues on Windows (because of font caching which needed to be rebuilt/reloaded each time font changed, I think it was something like this), but even this has been handled in the recent years (basically this was also put as a background process).

Edit: in intro, I obviously meant “GIMP does not access the network ‘constantly’” and not ‘on startup’ (since as explained, it does access this one file on startup, but only sometimes and it doesn’t wait for it).

See Edit > Preferences > Folders and search for folders that aren’t on a local disk…

Well, I ran through the whole exercise again (note I began with my laptop disconnected from the VPN), and here are the notes I took:

5:34 Clicked on GIMP shortcut to start the program. ‘GNU Image Manipulation Program’ appeared immediately in “Background processes” under the “Processes” tab and ‘gimp-2.10.exe’ appeared immediately under the “Details” tab in Task Manager
5:46 (Splash screen never appeared, though it has in the past. In the past when GIMP was starting slowly, the various plugin files that I assume GIMP was loading, would be printed in the splash screen window, though it took a long time to cycle from one to the next.) ‘GNU Image Manipulation Program’ now listed under ‘Apps’ on the ‘Processes’ tab in Task Manager. GIMP now available and responsive, so I tried to open a 2.7 MB JPG image that I had edited earlier when GIMP ran great, due to my laptop being connected to my work VPN. File request dialog did not close immediately upon clicking ‘open’ after selecting the JPG image, and I could move the request dialog around, though I could not select any other files or click the dialog buttons.
5:59 Image appeared, file request dialog disappeared. Performed minor edit and chose to ‘Export As’ and created new name at 6:00. About 6:19 a dialog for JPEG options opened and allowed me to complete the file save.

6:20 Reconnected to my work’s Cisco VPN, and started GIMP. It took about 10 seconds. Then I opened the same file in about 3 seconds, and exported it in about 4 seconds.

Please note my organization uses Onedrive which has caused file/folder access problems in other programs, but the relevant path for ‘Temporary folder’ and ‘Swap folder’ in GIMP preferences are both local at C:\Users{my username}\AppData\local\Temp\gimp\2.10\

A problem with OneDrive is that drives that exist but are not “mounted”
appear in the list of volumes on Windows, so actions like making a list
of folders for recently opened files, for file->open, for the file
chooser, and getting their names, have to wait for onedrive to time
out.

This could be that issue then: If network drives are not connected, there is a timeout before opening a local file (#8185) · Issues · GNOME / GIMP · GitLab

It’s in GTK 2.x, so not much we can do, but it seems to be gone in GTK 3.x and thus GIMP 2.99.x, at least.

I don’t think the problem is the same as issue #8185 because this problem involves much more lag time; ~40 minutes rather than ~40 seconds.

My IT support at work thought that perhaps the folders under C:\Users\{my username}\Appdata were being redirected to a server at my work, so I changed the ‘Temporary folder’ and the ‘Swap folder’ in GIMP preferences to ‘C:\temp’ to be sure they pointed to a location on my laptop. This produced the same symptoms, offering no improvement. I still have to connect to my work VPN for GIMP to start and open/save files in quickly.

You could try to see if any specific folder is being accessed, Microsopft’s Process Monitor tool can be useful there: Process Monitor - Sysinternals | Microsoft Learn

IIRC there is a 10 minutes time-out somewhere in TCP/IP, so that would be four accesses.

Did you try to just disable your TCP/IP interface (Ethernet and/or wifi)? This would cause an instant error and not a time-out. Of course this is not a long term solution but that could clear out some hypotheses.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.