Gimp on 2160p Monitor at 150% Upscaling

Some icons and text in GIMP are still extremely small on high DPI monitors, even when the operating system is upscaled to 150%. I’ve looked everywhere in the settings for a way to fix this and, even after several years of people complaining about this issue, it does not appear to have been resolved. Or, am I missing something?

What version of GIMP on what platform is this about?

The current, latest stable version (2.10.34), on a clean Windows 11 installation with all the latest drivers - AMD 5800x CPU, AMD RX6600-XT GPU, 32 GB RAM, NVMe SSD, Samsung 28" IPS UHD (3820 X 2160) monitor at 150% Windows scaling… (I tried the latest Beta version (2.99) and it wouldn’t even run.

This won’t change with the 2.10.x versions, as GTK 2.x doesn’t handle high dpi screens very good (or at all).

You should try to figure out why exactly GIMP 2.99.x isn’t running on your system - with its GTK 3.x, support for high dpi screens is there, and it is running reasonably well for many people, so if there is anything to fix to make it run on systems like yours, you might be one of very few people to point out what exactly.

Does “wouldn’t even run” come with any specific error messages?

Thanks! I installed 2.99.x, and when I tried to launch it, all I got was a windowed command prompt with a flashing cursor - the kind you type text commands into - and nothing more. I didn’t try to resolve the issue. If you have suggestions I might try to get 2.99.x running, I’d appreciate hearing them.

You might leave it running for an hour or so - it might be trying to
access e.g. a Microsoft OneDrive folder on startup.

And of course check with alt-tab or the process monitor to see if
there’s a gimp.exe or gimp-2.99.exe running.

The first time GIMP runs it will try to check for an older
installation, and also make a list of all your fonts, and in some cases
this can be really slow.

You were right, of course. I uninstalled the stable version, cleared all the related temporary folders, then installed 2.99.x. I launched it and gave it a few minutes and it did finally run. However, everything is still about the same size. The icons across the bottom are quite small, but I have a feeling that is just how the interface is designed. I though their might be an option to scale everything up, but I don’t see one.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.