Gimp layers will not stay selected

Gimp worked well for some time. No update installed but the layers will not remain selected, i.e. I can move a layer but not scale it. I have uninstalled and reinstalled twice and reset tool to default. I have installed gimp on another laptop and it works fine. Any thoughts?

What happens when you try to scale a layer? Can you show us a screenshot of the full GIMP user interface right before you are trying to scale a layer?

What Gimp version? 2.10.32 (stable) or 2.99 (dev)?


  • The Move tool can move a layer, the selection mask or a path (make sure its the layer):


  • When moving layers, the Move tool has two modes of operations, one where it selects the layer that you click on and leaves it as the active layer after the move, and one where it just moves the active layer:


Michael - thanks for getting back with me. I will send you screenshots in the next couple of days. I appreciate your help. - Fred

Using GIMP 2.10.32 (revision 1)

Apparently I can only send you two screenshots at a time ???

Set up screenshot

Attempt to scale

I will attempt to send you additional screenshots if needed

Thanks Michael

I’ll note you have the scale tool in Corrective mode, so if you hit enter now, the layer will get larger (and you’ll need to use Image->Fit Canvas To Layers to see it all, probably). If you switch to Normal instead of Corrective (in the Tool Options to the left of the image) you can turn on Image Preview.


Are you saying that is why the layer deselects and I am unable to scale?

Thank you – I tried to scale and it worked.

Am I wrong that the layer should remain selected in both Pick a layer and Move the Active Layer?

Thanks Liam

Am I wrong that the layer should remain selected in both Pick a layer
and Move the Active Layer?

The move tool does not select layers. It moves either the topmost layer
with a non-transparent pixel under the pointer (default), or the active
(selected) layer.

Use the Layers dialogue to select layers.

The move tool does not select layers.

Sorry but this is not true. If you use the Pick a layer or guide mode the last layer moved (or even clicked) becomes the active layer. The only exception (sort of) is that if you activate the mask of a layer, move other layers, then click back on that layer with a mask, the layer mask is selected, and not the layer itself.

That’s certainly not the behaviour i see.

Maybe it’s changed? In which case the reporter has identified a change
that might be a bug or might be deliberate… :slight_smile:

Thanks – I haven’t gotten into masks yet….

Thanks for all your help

Arumph. Actually that’s an option:

It must be quite popular…

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.