GDK-Pixbuf-Thumbnailer problem with Pentax RAW

My first post here and I hope I’m doing this in the right place.

I was using Mint until I needed to switch to Ubuntu and chose the Cinammon version.

In Nemo under Mint, all thumbnails showed even for the RAW files. In Nemo under Ubuntu Cinnamon, this isn’t happening. I did a check of what little I knew on both platforms and came up with very little.

On checking the /usr/share/thumbnailers/gdk-pixbuf-thumbnailer.thumbnailer file I enacted a fix that I found on the internet which was to add various other mimetypes to the variable and this worked for Cannon raw files, however, the Pentax RAW files just come up as white. They process… they just return white thumbnails.

I have drawn a dead end with my limited knowledge and have come here for help.

Do not change system files with whatever you read on the Internet.

The thumbnailer provided by gdk-pixbuf does not support, nor has ever supported, random RAW files. Some RAW files embed a JPEG preview, and may be opened as a JPEG file, which is how you’ll get a low quality version of the picture good enough for a small thumbnail.

There are thumbnailers for RAW images, in various states of maintenance; you will have to install those.

For more information, you can read these issues:

1 Like

Thanks for this. Looks like I’m going to have to go through Mint’s default installation and see what it’s installed to supplement gdk-pixbuf. If you’ve got any info that could give me a starting point on this, I’d be grateful.

It appears that they have a number of extra thumbnailers. I tried to install the xapp-raw package, but it has unmet dependencies, so I’ll work my way through it.

Got it.

There was an xapp-thumbnailers-common which I had to get for Mint Vera and once that was in, then xapp-raw-thumbnailer for vera also installed and after a restart of Nemo, it’s working.

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.