File-Roller Question: Restoring Owner:Group

I have started using GNU tar for scripted OS backups since GNU tar is pretty universal in the Linux/BSD worlds. Restoring from the Bash shell using just the tar command works without a hitch as long as root is doing the restore. I can restore any files or directories and the owner:group and perms are reproduced perfectly.

However, I wanted to use a GUI application for a few other users to make their lives easier. Since we use Gnome, I defaulted to File-Roller. However, no matter how I’ve tried, the restored files reflect the default owner:group of the user doing the restore. Initially I thought it was an issue of needing to run File-Roller as root. No change. All files are owned by root:sys when restored. (I am using Ubuntu 22.04).

I tried a few other GUI based alternatives but none of them worked, and I’d rather rely on what we already have installed anyway. I did not find any options to allow preserving owner:group/perms, and a few other forums just indicated it was not possible with File-Roller, but I wanted to get an answer directly from the project! :slight_smile:

Basically, a simple, “No there is no way to restore and preserve owner:group” is all I need so I can move on. Additional info as to why this limitation exists, isn’t necessary but would be helpful if it is know. And if this is the wrong part of the forum to post this in, please let me know.

Thank You,
George

For anyone else looking for an answer, I eventually decided to just use ‘tar’ and document the restore procedure for the other admins. None of the GUI based applications I tried seem capable of restoring owner:group, and this is likely a security choice as it isn’t wise to run GUI apps as ‘root’. Distros have always discouraged this, either by denying root execution, or warning at GUI login that you are logging in as root.