External monitor stays in power save mode in GNOME40 (black display)

Hi,

I noticed that my external monitor enters and stays in power save mode immediately after system start (or in other words it does not display anything at all from the very start) in various Linux distributions with GNOME40 i.e. Fedora 34 or Clear Linux when it is connected by DisplayPort. I would like to ask for the advice. What can I do to resolve the problem?

In GNOME settings I see two displays, my Surface display and DELL U3415W external monitor. In Gnome Settings on my Surface display, I have the ability to set resolution and refresh rate on both displays without any problems. However DELL external monitor as I mentioned stays black when connected through DisplayPort. When I connect this monitor through “DisplayPort to HDMI adapter”, the monitor wakes up and displays 3440x1440 but with only 29.99 refresh rate. When I connect DisplayPort cable again, it becames black. On Ubuntu 20.04 (not Gnome 40) the monitor does not have any problems to work with DisplayPort at 60 refresh rate nor there are any problems on Windows 10.

Below please find some xrandr info taken in Clear Linux:

######################################
CONNECTED miniDP
######################################
clrlinux@clr-live~ $ xrandr
Screen 0: minimum 320 x 200, current 5360 x 1440, maximum 16384 x 16384
eDP-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 235mm x 132mm
1920x1080 59.97*+ 59.97 59.96 59.93
1680x1050 59.95 59.88
[…]
320x180 59.84 59.32
DP-1 disconnected (normal left inverted right x axis y axis)
HDMI-1 disconnected (normal left inverted right x axis y axis)
DP-1-8 connected 3440x1440+1920+0 (normal left inverted right x axis y axis) 798mm x 335mm
3440x1440 59.97*+ 49.99
2560x1440 59.95
[…]
720x400 70.08
DP-1-1 disconnected (normal left inverted right x axis y axis)

####################################
CONNECTED miniDP to HDMI APAPTER
####################################
clrlinux@clr-live~ $ xrandr
Screen 0: minimum 320 x 200, current 3440 x 2520, maximum 16384 x 16384
eDP-1 connected 1920x1080+779+1440 (normal left inverted right x axis y axis) 235mm x 132mm
1920x1080 59.97*+ 59.97 59.96 59.93
1680x1050 59.95 59.88
[…]
320x180 59.84 59.32
DP-1 disconnected (normal left inverted right x axis y axis)
HDMI-1 connected primary 3440x1440+0+0 (normal left inverted right x axis y axis) 798mm x 335mm
3440x1440 29.99*
1720x1440 60.00
[…]
720x400 70.08

Is there anything that I can do to make the DisplayPort connection work or to make connection through HDMI usual 60 refresh rate? I doubt the HDMI 60 possible however I decided to ask about it as well. My priority is direct DisplayPort connection.

Thank you.

Guys,

I also posted this question at Clear Linux discourse: External display stays in power save mode in GNOME40 (black display) - Q&A - Clear Linux OS Forum, however I think it is related to Gnome40 or maybe to Wayland. I would really appreciate some advice on this topic.

Many thanks in advance.