Evolution: Webkit editor plugin broken since 3.46.1

In February I’ve been told on the Evolution mailing list how to change the default font for outgoing HTML mail via webkit editor plugin: Re: [Evolution] Setting default font for outgoing HTML mail.

Since then I’ve had the following in ~/.local/share/evolution/webkit-editor-plugins/body-font.js:

'use strict';

var localhostBodyFontPlugin = {
   name : "localhostBodyFontPlugin",
   setup : function(doc) {
      if (doc.body) {
          doc.body.setAttribute("style", "font-family: Calibri,sans-serif; font-size: 11.0pt;")
      }
   }
};

EvoEditor.RegisterPlugin(localhostBodyFontPlugin);

This has been working fine until Arch had the upgrade from 3.44.4 to 3.46.1 hit its repositories. Now it seems to not get executed and I don’t get an error message or unusual output either.

Any ideas what might have broken my plugin? Thanks!

This is kinda interesting. One of the changes in the 3.46.1 is that there had been enabled sandboxing for the WebKitGTK, which prevents access to the home folder, thus the code doesn’t know the plugin exists.

A workaround is to run evolution with the sandboxing off:

$ WEBKIT_FORCE_SANDBOX=0 evolution

You can also add export WEBKIT_FORCE_SANDBOX=0 into the ~/.bashrc or similar file, but it influences every application, which uses WebKitGTK, not only Evolution, in such case.

A bug report in Issues · GNOME / evolution · GitLab would help, thus this is not forgotten.

Never mind, I just fixed that for 3.47.1+ and 3.46.2+ (https://gitlab.gnome.org/GNOME/evolution/-/commit/f380159524e7a3544fad3135e00b65534710b757)

1 Like

Your’re fast! I already created an issue and closed it right away when I saw your second comment.

Thanks for the quick help and proper fix! I’ll keep using the workaround until f3801595 hits my distro.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.