Evolution: Unable to access address books "On this Computer", from any email accts., when sending new email

If I have created this topic in the wrong category, I apologize.

Evolution.: 3.28.5 (3.28.5-21.el8)
OS CentOS 8 stream

In mail I have 4 different email accts created, one of which is “On This Computer”
In Contacts I have 5 Address books created, ‘Business’, ‘Employment’, ‘Family’, ‘Finance’, and ‘Friends’.
In Contacts there is also an Address book ‘Collected Addresses’
In Contacts I have 3 Groups, ‘On This Computer’, ‘example1@gmail.com’ and ‘example2@gmail.com’.
In Contacts under On This Computer I see all 6 address books, under both x@gmail.com I have ONLY
‘Contacts’ address book.
In Contacts, when I select ‘Manage Groups’ the pop-up has options ONLY for up/down.

Issues
In Mail it does not matter which account I choose to draft email from, the ONLY address book which shows any contacts is the “Collected Addresses”, all other address books are blank/empty when I select them from the drop down Address Book option.

I have spent days combing through online evolution manuals and blogs searching for a solution, obviously I have found nothing, so any assistance here will be greatly appreciated.

I am experiencing the exact same issues in the ‘Calendar’ page, same ‘x’@gmail.com accounts are listed, but I am unable to get all of the 6 calendars I have created to be associated with all of the email accounts I have created.

I am trying to get as much of the t-shooting issues noted here to avoid the amount of back/forth questions/answers posts issues like this generates, so forgive if it appears I am droning on.

Last note: when I go to Edit > Evolution Accounts
in the popup I have both the ‘x’@gmail.com accounts, both are enabled, both are ‘google’ in the ‘Type’ column. However, under the lower or second account, listed there is ‘Mail Accounts’, ‘Address Books’, ‘Calendars’, ‘Memo Lists’, and ‘Task Lists’. When I expand the ‘Mail Accounts’ I can see the other 2 mail accounts I have created, in the ‘Type’ column they both show ‘imapx+smtp’. Any attempt to edit these only opens the email account settings for that account. When I expand the ‘x’@gmail.com accounts in this same popup there is a sub category ‘Mail Accounts’, just like the aforementioned with the 2 ‘imapx+smtp’ accounts. However, both of the ‘x’@gmail.com accounts have their respective accounts listed with the same ‘imapx+smtp’ noted in the type column.

So maybe I’m an id10t here… but should not the two ‘imapx+smtp’ accounts also be listed exactly like the xgmail.com accounts? I have tried adding/removing these several times, and that changes nothing.

All sending/receiving works fine, outside my inability to access the address book.

The first thing I will point out is that Evolution 3.28 is really old: it was released in 2018. If possible you should consider upgrading to a newer version.

I don’t have access to such an old version, but in my version of Evolution (3.46.2), I would go to Edit → Preferences and choose the “Contacts” tab, and verify that all my address books were checked in the “Autocompletion” section.

Thank you,
I will see about updating Evolution immediately, this was a new CentOS build last week, so I assumed I had the most updated v/of Evolution.
And…
Yes, I have verified all my address books are checked in the Autocompletion section as noted.

It’s important to note that for “stable” or long term support distributions, it would be very unusual to switch to a newer full version of software, within the lifetime of the distribution.

So, if you are using OS CentOS 9 then you will get the newest bugfix versions of whatever software major versions were provided with that release when it was shipped. So, if CentOS 9 was shipped with Evolution 3.28.1 you may get updates to 3.28.2, 3.28.3, etc. to provide bugfixes and critical security fixes.

But, it’s highly unlikely you’ll get an update to Evolution 3.30, 3.32, or above, where the user interface etc. may change. That’s what people who choose “long term support” or “stable” releases are wanting; distributions that don’t change the user interface or user experience until/unless they choose to update to a new release of the distribution.

I don’t use CentOS systems so I can’t explain why CentOS 9 (which was released in 2021) is still using such an old version of Evolution (released in 2018).

But just updating to the newest set of CentOS 9 packages will almost certainly NOT get you a new major version of Evolution.

You might consider installing the flatpak version of Evolution. I don’t know what the flatpak status is on CentOS 9, but I use the flatpak version of Evolution on my Ubuntu 20.04 LTS system (which is even older than yours) and it works great.

However, I have no idea if this will solve your problem. All I can say is that I have a number of address books across different email accounts and autocomplete works with all of them.

Again, thank you for your assistance on this.
Correcting my error: I am running CentOS Stream 8, NOT 9.
I recently purchased a new mini pc, I am using Debian an my old pc but it was in desperate need of being replaced. I had a lot of issues getting Nix loaded on this new pc, after attempting numerous times with Debian, Ubuntu, Kali, etc. I finally found this site:

I could have saved myself a weeks worth of headaches and sleepless nights had I found that first, either way that was what has generated my confusion on which version I am actually running.

This is my first taste of CentOS, so there is a learning curve there as well.
This link to CentOS 8:
https://pkgs.org/search/?q=evolution
Has only evolution v3.28.5 (3.28.5-21.el8) available for CentSO-8. After a considerable amount of time spent on trying to get this one software package working correctly I was finally able to get all of the dependencies addressed. Below is a list of all the evolution packages I now have installed.
evolution-3.28.5-21.el8.x86_64.rpm
evolution-bogofilter-3.28.5-21.el8.x86_64.rpm
evolution-data-server-3.28.5-20.el8.x86_64.rpm
evolution-data-server-tests-3.28.5-20.el8.x86_64.rpm
evolution-ews-3.28.5-13.el8.x86_64.rpm
evolution-langpacks-3.28.5-21.el8.noarch.rpm
evolution-mapi-3.28.3-7.el8.x86_64.rpm
evolution-pst-3.28.5-21.el8.x86_64.rpm
evolution-spamassassin-3.28.5-21.el8.x86_64.rpm

I of course updated/backed up etc. However, I am still in the same boat as I was in when I started this topic.
First Issue: I have 2 ‘x’@gmail.com accounts, 1 ‘x’@outlook.com, and 1 ‘x’@'a-private-domain’com. None of these will pull contact details from any Address book, other than Collected Addresses.
Second Issue: I am experiencing similar behavior with the Calendar, the only accounts in the 'Managed Group" drop down are the ‘x’@gmail.com accounts, and the behavior for those 2 gmail accounts is not consistent between the two, meaning I am seeing different issues between each of them.

My next step will be to update/backup/shutdown evolution, attempt once more, then I’m going to remove these accounts one at a time and see if my adding them back in corrects this. I’m thinking maybe I added them wrong to begin with???

Anyway, thank you again for your assistance with this, your time and efforts are appreciated.

I have removed 2 gmail.com acct., and then added them back, no change.
I then removed the outlook.com acct., and added it back, no change.
I find it odd that under Contacts, Calendar, Tasks, and Memos, I have an option to ‘Manage Groups’, but you can only remove them, or move them up/down. Once I remove them I have not been able to add them back.

I thought this might be a solution, I copied all the contacts I have in each address book into the ‘Collected Address’ book, thinking this would then give me access to them when I access that address book from within the send mail option. That too failed, they are just not there.
However, one of my contacts popped a warning that it already existed, so I merged them. I then access that contact inside the Collected Address book, changed the ‘Where’ drop down from Collected Addresses to the Friends address book and now when I access the Friends address book from withing the send mail drop down that singe contact is available… NO THIS DID NOT WORK WITH ANY OTHERS… LOL, I tried doing the same process with several others, and it failed…

I’m about to juist throw in the towel here and move on…

As I said I can’t help you with such an old version of Evolution. All works well for me with multiple address books including gmail contacts and Exchange address books.

If you are forced to use such an old distribution of GNU/Linux like CentOS 8, you will have a tougher and tougher time as software ages out, unfortunately.

In a previous message I suggested looking into installing the latest version of Evolution using flatpak; did you discover whether that would work on your system or not? My reading suggests it is supported on CentOS 7 and higher. If you install flatpak you can run:

  flatpak install evolution

(or maybe it was flatpak install org.gnome.Evolution I can’t remember) to get a newer Evolution.

I’ve used Evolution for a long, long time (including, back in the day, Evolution 3.28) and I don’t recall these problems. But, I’ve never used CentOS on the desktop, only Debian/Ubuntu, and back then I didn’t need anything other than gmail contacts, which did work.

Hi,
you do not need evolution-mapi, it’s for old Microsoft Exchange
servers, like 2003.

You may or may not need evolution-ews, it depends how you configure the
outlook.com account (which is unclear from your text).

You get contacts automatically only for known accounts (like Gmail), if
you let them be created, which means the accounts is a “Collection
Account”, not a bare IMAP (or other) mail account. Again, I’m unsure
from the text how you configured it.

Nonetheless, I agree with Paul, it’s useless and waste of time to use
such outdated software. I do not know why you picked CentOS 8, whether
it’s forced by your company or you “just picked one operating system
semi-randomly”. You might want to pick something more recent, and if
you do not need LTS (Long Term Support), then you can get the fresh
bits of everything. Of course, it can have its disadvantages to be on
the bleeding edge.

As Paul suggested, give a try to the Flatpak version. It has its
limitations, but it’s perfectly suitable for the LTS distros, to get
the latest stable version of the Evolution. It should be as simple as
running from a terminal:

$ sudo yum install flatpak

though it is claimed to be pre-installed here:

https://flatpak.org/setup/CentOS

The setup guide for the CentOS on the Flathub.org repository is a bit
sparse:

https://flatpak.org/setup/CentOS

and, to be honest, touching Flatpak for the first time I’d not
understand what they mean. The command from the Fedora setup page will
work anywhere:

https://flatpak.org/setup/Fedora

(when you open the Flatpak—the future of application distribution page you get guides for
many distros). Once you’ve the Flathub enabled, you can:

$ flatpak install flathub org.gnome.Evolution

which will install it. After that the icon to run Evolution will start
the Flatpak version, not the host system version. You can run it also
from a terminal as:

$ flatpak run org.gnome.Evolution

You can see what version you use in Help->About menu, but you should
see a visual difference as well.

The above flatpak commands will work with the system repository. You
can install all of it for you only, when you add --user to each command
(including when installing the Flathub.org .flatpakref file).

Also, the summary of this issue mentions On This Computer. Check
Edit->Preferences->Contacts, there’s a list of the known address books
and those checked are used for the autocompletion. Maybe you’ve some
books unchecked for whatever reason.

You mentioned the Manage Groups, that’s only a visual thing, to hide
groups, which you do not use. One cannot hide a group (other than
Address Book), which has enabled sources. Otherwise you can hide a
group and show it back, depending whether the group is checked or not.
It doesn’t have other functional behavior, it influences only the view
where you use the menu option, basically only the left list of the
available sources.

I’m sorry I mixed multiple things together, instead of replying to the
individual messages, though I guess it’s better to be on a single
place.

Bye,
Milan

Thanks to all,

Covering multiple topics in one post is fine, i can track.

No, this OS version was not company enforced, my com. uses M$…

This was a new install on a minisforum hx90, a new pc I recently purchased. Installation attempt with Ubuntud, Mint, Debian, and Kali all failed, I was finally able to get CentOS 8 to load, and so I ran with that. Obviously will have to upgrade that to CentOS 9, probably today if I have time later.
This site will detail the pains I went through, unfortunately I had CentOS 8 loaded and running before I discovered it.

I would prefer to load/run Kali or Debian, but neither of those OS’s play well with the minisforum, I believe that is due to a lack of support for eihter UEFI or USB install methods, additional details can be found on the link I provided.

I upgrade to CentOS 9 and then update this post agai.

Thanks all,

Hi,
if you do not need Long Term Support, would you mind to give a try to
Fedora ( https://getfedora.org ), please? I do not mean it as an
advertisement, it’s just that the CentOS is derived from it, the CentOS
is only behind the current upstream development, even the CentOS 9. If
the CentOS worked, then maybe Fedora 37 will work as well (it contains
the current Evolution, the 3.46.x series). It would worth a try, if you
have time and bandwidth, to get the latest version. No big deal if not.
Bye,
Milan

ok, yeah, you are correct.
I have now dumped Centos 9, due to the large number of applications I was unable to get working.
I have now installed Kali, v2022.4, kernel 6.0.0-kali6-amd64
evolution is 3.46.2-1

I am still having the same issues with evolution. I spent all night up installing and customizing my build, all the other packages I have installed work fine, Brave web browser, GNUCash, Libre Open Office, Remmina, etc.
The fact I am having issues with only evolution, point to the problem being a pebkac… I dont like being the problem, lol.

anyway, ill drop more details later on exactly what my issues are but right now i need to get some rest.

Thank you,

so, even w/v3.46.2-1 I’m seeing the same issues.

Mail accts. contains: 2x-gmail.c0m, 1x-outlook.c0m, and 1x-‘private’.c0m

Contacts contains: 1 entry titled “On This Computer”, which contains 5x-Address Books
-Address Books: Collected Addresses, Business, Employment, Family, Finance, and Friends.

Calendar Groups contain: On this Computer, 1x-gmail.c0m, 2x-gmail.c0m
-Calendars: On this Computer contains: Home/Personal, Appointments, Birthday&Anniv., Business/Finance,Employment, Events, and Holiday in US.
-Calendar: 1x-gmail contains: Birthdays, Family, Holiday in US.
-Calendar: 2x-gmail.c0m contains: nothing

Tasks contains: same as Calendar

Memo contains: On this Computer

Issues:

  1. when i open a new email, and I select ‘To:’ the ONLY address book which contains addresses I can select from is the Collected Addresses, all the other are blank, with no entries. However, when in the Contacts page all address book contains entries.
  2. when in the Contacts page and i copy an entry from any other address book to the Collected Addresses book, that address is still not available when I open a new email, select ‘To’, and access the Collected Address book.
  3. when in the Contacts page and ‘rt’ click to select ‘On This Computer’ the ‘Manage Groups’ options shows ONLY ‘On This Computer’, with options to move up/down or hide, there is no option to add.
    3.5) when in the Calendar page and ‘rt’ click to select ‘On This Computer’ the ‘Manage Groups’ options shows On This Computer, Contacts, 1x-gmail.c0m, and 2x-gmail.c0m. Each of the Groups in the Calendar page has different calendars listed.
  4. when i access Edit > Accounts: Evolution Accounts box opens, this contains 1x-gmail.c0m Type Google, 2x-gmail.c0m type Google, and then a Mail Accounts, Address Books, Calendars, Memo Lists, and Task Lists options. Expanding each of the Type Google accts. presents the same options as seen below, Mail, address, etc. Expanding the Mail Accounts under each of these details the x-gmail.c0m accts. and then type imapx-smtp. Expanding the Mail Accounts option show the other 2 .com accounts, and the same data.

I have checked the properties, and manage groups options on all of the above and still I am failing at fixing this. I’m sure it’s a setting somewhere that I’m not not seeing, and I suspect it’s within this ‘Manage Groups’ details.
I am really not concerned with the issues under Calendar/Tasks/Memos, but I would really like to have the ability when in Mail to pull addresses from my address books.

P.s. when in Mail and I select Message > Add Sender To Address Book > I have the option to select which address book that sender is added to, after that I do see that sender in the address book I chose when in the send mail section. So, I can manually add senders to the address books I have created, and have access to them, but i do not have access to old entries in the address books I have created.

Any/all help is greatly appreciated.

Thank you,

Contacts contains: 1 entry titled “On This Computer”, which contains
5x-Address Books
-Address Books: Collected Addresses, Business, Employment, Family,
Finance, and Friends.

Hi,

this does not make sense to me. I do not know what you’ve done, but the
On This Computer always contains “Personal”, in all views. You can
create other address books, calendars, … under it, but they are never
created for you (except if using SyncEvolution, I think).

In any case, the Contacts view (Ctrl+2) should show something like
this:

On This Computer
Personal

1x-gmail.c0m
Contacts

2x-gmail.c0m
Contacts

and maybe other Google books, if there are configured more.

When you are in the Edit->Accounts, you can select the “1x-gmail.c0m”
account (the one with type “google”), which allows you click on the
Edit button, where you can enable/disable certain parts from there. I
guess you’ve everything enabled.

The Manage Groups, it’s only for the groups, like “On This Computer”,
“1x-gmail.c0m” and so on. It’s not for individual address
books/calendars/… We’ve talked about it earlier.

I can manually add senders to the address books I have created, and
have access to them, but i do not have access to old entries in the
address books I have created.

This is really, really odd, it doesn’t make any sense to me. It looks
like a configuration issue to me, broken local caches, something like
that.

How did you get the newer evolution (and evolution-data-server),
please? Was it by an update, after which you restarted all the
background processes (or the whole machine), thus the newly installed
software is in use now?

You can also start the addressbook factory from a terminal, maybe it
prints some errors there. It can be done, before starting evolution,
with:

/usr/libexec/evolution-addressbook-factory -w

the actual path can differ in your distribution.

When I click on the To button in the composer, the dialog shows three
options to limit which contacts should be shown, the address book, the
category and the search text. These options are not remembered, they
are reset to their defaults as soon as the composer window closes. As
the default is to show the any category and the search text is empty,
there should be no filtering except of showing only contacts with email
addresses filled.

If this is a configuration problem, then I suggest to start from
scratch. The easiest would be to test with a new user, or you can close
Evolution and then move away relevant directories:

~/.cache/evolution
~/.config/evolution
~/.local/share/evolution

I really mean to move them away, not to delete, especially the
~/.local/share/evolution, because it contains everything you see under
the On This Computer, thus if you’ve there any mails, contacts, events
and so on, you’ll lost that when you delete the directory.

Then restart the background processes:

evolution --force-shutdown

and then, when you start Evolution, you should be asked to configure a
mail account, when in the Mail view. This cleanup should help, if there
is a cache/data problem. It’s a heavy hammer, but your evolution
misbehaves really oddly.

Bye,
Milan

Milan,

You did it, you helped me fix this.

I was reading over your post, and typing up my responses and it made think back on how I imported the contacts.
They were imported from Thunderbird, but I had imported them as Evolution contacts, when I went back and re-imported them as Mozilla contacts everything worked out exactly as it should.

Thank you very much for your time,

V/r
drogers

Hi,
I see. The import might write the email addresses into wrong fields
then, or ignore them altogether, or some such thing, I guess.

Good you found the reason and fixed it.
Bye,
Milan