Evolution shows starting error about calendar

I’m on Fedora-39Beta and I’ve just switched to Evolution from Thunderbird. I’m getting this message “Failed to connect calendar {details} Failed with HTTP error 400: Bad Request”

I don’t want a calendar and can’t see any way to switch it off either in the app help or online help.

do you know what calendar it is, please? It can be On The Web or
CalDAV, I guess. Something configured it for you, maybe the GNOME
Online Accounts, can be found in Settings->Online Accounts under GNOME.
Evolution(-data-server) does not configure remote calendars on its own.

The Fedora-39Beta, I guess it means Evolution 3.50.1, right? It can be
seen in Help->About menu from the application of from terminal:

evolution --version

or in case of Fedora:

rpm -q evolution

The thing is the app version is more important than the distro version
(also because distros do update apps from time to time).

When I click “Reconnect” it comes up with a panel entitled “Yahoo task list authentication request” and I sign in to my account. Warning comes back again.

These are all blank, they just ask for account details

Version: Good point, it’s 3.50.0 (3.50.0-1.fc39)

I see, in that case it’s configured directly in Evolution.

Did you configure a Yahoo! mail account with OAuth2 authentication? I guess so, but I do not know for sure.

In any case, if you are not going to use the calendaring part of the Yahoo! account (which includes events, tasks and memos), then you can open menu Edit->Accounts, find the Yahoo! account there and then disable anything you do not want to use from it. You can also double-click the top account name, which will open an Edit of the collection account, where you can enable whole parts (Mail, Calendar, Contacts) to be used or not.

1 Like

That’s fixed it, thanks. I’ve got other problems with switching from Thunderbird, but I should probably post another query for those.

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.