Evolution: option to include more than final message in reply

I recently updated to Evolution 3.44.4, having been stuck on whatever version comes with Fedora 30 for some time. Since the update, whenever I hit reply to an email, only the most recent message is included as quoted below, with all earlier messages deleted. I can see the point of reducing the size of emails in long threads, but this is too restrictive. How do I change the settings to include more history? I can’t find anything relevant in Preferences.

Oddly, when I was searching online to see if I could find a solution, I found a fairly recent thread on this forum, bemoaning that they wanted to limit quoted messages in a reply to only the last message, but could not do so. This thread dates to after I started having the problem that I can only reply with the most recent message.

I note that nobody replied to say “just update to the latest version”.

So if other users don’t have this “feature”, and want it, is my installation somehow screwed up?

To be clear, as there seemed to be confusion on the original thread. I’m talking about evolution mail. Not discourse, which I have never used before!

I assume this is not about threaded selected reply levels, but about people who reply on top and quote a full previous email at the bottom (which is frowned upon). If you or someone have a signature defined, then it is intentional that the signature and everything below (!) the signature gets stripped.

Do you have enabled “Edit > Preferences > Composer Preferences > General > Keep signature above the original message”? If yes, try switching it off.

Hi,
I believe the message you reply to contains a signature delimiter,
which looks like “-- \n” (quotes for clarity only and the “\n” is a new
line, thus “dash dash space new-line”), which is recognized and
everything below it is stripped, because nobody should write below the
signature (and because you do not want to see millions of signatures in
the message).

Signature stripping can be disabled in GSettings (or dconf-editor), try
to execute:

gsettings set org.gnome.evolution.mail composer-reply-keep-signature true

That the old/ancient Evolution you used before did not strip the
signature could be because it did not recognized the delimiter. There
had been some improvements made to enhance the detection.

Bye,
Milan

P.S.: if you are still on Fedora, then the current one is Fedora 37,
which brings Evolution 3.46.x, which is the latest stable series at the
moment. Not that it changes anything, I’m just saying so.

Brilliant, thanks!! Yes, I know Fedora was updated again. I can only update when I have the time to cope with the risk of that breaking things, as I use this machine for work.

It’s frowned upon in tech communities, I know. However in other community contexts it’s absolutely expected. Just depends on who you’re talking to.

To be clear, the fix suggested by @mcrha worked perfectly.

I would be happy to mark this topic as closed but I can’t see how to do that. Do we just leave resolved issues to automatically close after a month? Fine with me but I don’t want to clutter your threads.

Hi,
no cluttering from my point of view, just let the thread expire on its
own. It’s okay.
Bye,
Milan