Evolution, Gnome Calendar and Google Calendar

Hi, I posted on the Fedora forum yesterday and have had no responses, but suspect it is more of a Gnome question…

The crux of my problem is that I cannot get Evolution to fully synchronise with my Google Calendars.


I had a Fedora 36 laptop with Evolution set-up with two EWS (MS Exchange) accounts, a Google account with multiple calendars and tasks and one IMAP account - as far as I was aware this was fully working, new events I created on the laptop showed on my phone and vice-versa.

I moved to a new laptop by doing a clean install of Fedora 36 and then copying over my home directory with rsync in archive mode while logged in as root on both laptops so nothing was accessing those files.

When Evolution opened on the new laptop the Google account email, calendar and tasks were showing in the sidebar but my IMAP account and the EWS accounts were missing and all of the calendar entries were also missing.

Eventually I discovered that I had been on Flathub Evolution on the old laptop and when I uninstalled Fedora RPM evolution and installed Flathub Evolution on the new laptop everything seemed to work again.

However, after a little while I noticed that I was not always getting events that I created on my phone appearing in Evolution BUT they were appearing in the Gnome Calendar application - i then spotted there were two copies of every evolution data service program running…

What I’ve tried…

Uninstalling and reinstalling Evolution from each of the 3 repositories and removing and then re-adding the Google account.

Uninstalling Evolution, killing all Evolution processes removing all of the config and cache: “rm -f -R .var/app/org.gnome.Evolution .local/share/evolution .config/evolution .cache/evolution” and then reinstalling Evolution, connect the Google ‘Online Account’ and then starting Evolution.

At one point early on I think I even started with a new home directory and tried to get that to synchronise the calendars.

However, at best, only one of my Google calendars ever has its events synchronised (even though they all show in both Evolution and the Gnome Calendar app and I can click ‘synchronise’ on them in both applications).

Interestingly I can create events on either Gnome Calendar application or Evolution and the events appear on my phone, however, the event created on Gnome Calendar does not appear in Evolution and the event created in Evolution does not appear on Gnome Calendar.

I then tried installing evolution-ews from the command line (which I believe is the correct Fedora way of getting Exchange accounts and a ‘standard’ Fedora build of Evolution.

I briefly had calendars back working but as soon as I restored my evolution data from backup all the calendar content disappeared and disconnecting, reconnecting and refreshing calendars has failed to produce any events from Google Calendar showing in Evolution or in the Gnome Calendar application.

The Evolution package I’m now using is:

Installed Packages
Name         : evolution-ews
Version      : 3.44.4
Release      : 1.fc36
Architecture : x86_64
Size         : 2.1 M
Source       : evolution-ews-3.44.4-1.fc36.src.rpm
Repository   : @System
From repo    : updates
Summary      : Evolution extension for Exchange Web Services
URL          : https://wiki.gnome.org/Apps/Evolution
License      : LGPLv2+
Description  : This package allows Evolution to interact with Microsoft Exchange servers,
             : versions 2007 and later, through its Exchange Web Services (EWS) interface.

I’d be really grateful for any help as I absolutely rely on this functionality to manage my day…

Thanks in advance,


the Flatpak (no matter whether Flathub or Fedora) version of Evolution runs in its own sandbox, fully isolated from the rest of the desktop, not sharing the data with anyone. As long as your distro provides up-to-date Evolution (which Fedora does), use the native (RPM in this case) version of the Evolution. You not only save the data being downloaded and the disk (nothing is twice in the caches), you also get better desktop integration and overall better user experience with compare to the Flatpak limitations.

With respect of the synchronization with the events created on your phone, by any chance, do you have enabled Power Saver mode in the system? That exhibits the symptoms you described. When you turn that off and use “Refresh” on the calendar in the Evolution, you’ll get the events fully synchronized. The 3.46.0 will have this done better.

Thanks for the response I am indeed using the Fedora version of evolution now.

In terms of synchronisation, nothing is coming across; this is what Google Calendar looks like:

This is what Evolution looks like: (see next post)

i.e. its not that updates are coming across slowly - nothing is being pulled into Evolution from Google (whereas if I create an event on Evolution it appears in the Google Calendar).

What evolution looks like:

It occurred to me that I had been googling for ‘Evolution’ and Google calendar syncing so I tried looking for Gnome Calendar and found a couple more threads; this lead me to try…

Removing the Google Account

  rm .cache -f -R
   rm .config/goa-1.0 -f -R

Rebooting, Adding the Google Account, Rebooting.

By itself this appeared to do nothing. I then found another thread and did:

CALDAV_DEBUG=1 /usr/lib/evolution-calendar-factory -w 

And then unchecked and checked each of my calendars in the Gnome Calendar app - this then showed all the events being retrieved AND they then appeared in Evolution and Gnome Calendar.


I still haven’t found a way of getting my Google Tasks to re-appear in Evolution or Gnome To-Do (Endeavour) and it seems that calendar events created on other devices and sent to Google are not (yet?) appearing in Gnome Calendar or Evolution.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.